Bug 189062 - Remote ipp printers not seen in "Browsed Queues"
Remote ipp printers not seen in "Browsed Queues"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
: 189063 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-15 05:41 EDT by Michel Van den Bergh
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.6.151.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 07:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Replace ['printer-state-message'] by get('printer-state-message') to avoid triggering exception (609 bytes, patch)
2006-04-15 05:41 EDT, Michel Van den Bergh
no flags Details | Diff

  None (edit)
Description Michel Van den Bergh 2006-04-15 05:41:39 EDT
Description of problem:

FC6-devel test system does not have any local printers attached. 
There are two ipp printers on a server on the local network.
No "Browsed Queues" appear containing remote printers

Version-Release number of selected component (if applicable):0.6.151.2


How reproducible:

See description.





Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

The origin of the problem is that the latest version of pycups returns
*no* "printer-state-message" instead of an empty one if there is nothing
to report.
Comment 1 Michel Van den Bergh 2006-04-15 05:41:39 EDT
Created attachment 127778 [details]
Replace ['printer-state-message'] by get('printer-state-message') to avoid triggering exception
Comment 2 Michel Van den Bergh 2006-04-15 05:58:27 EDT
Filed under the wrong category.
Please see the corresponding bug in system-config-printer.
Comment 3 Tim Waugh 2006-04-15 07:51:59 EDT
What does 'rpm -q cups system-config-printer' say?
Comment 4 Tim Waugh 2006-04-15 07:52:49 EDT
*** Bug 189063 has been marked as a duplicate of this bug. ***
Comment 5 Michel Van den Bergh 2006-04-15 08:00:36 EDT
rpm -q cups system-config-printer returns

cups-1.2-0.4.rc2.1
system-config-printer-0.6.151.2-1
Comment 6 Tim Waugh 2006-04-18 09:12:57 EDT
Fedora Core devel has a completely re-written system-config-printer application.
 However, FC-5 will have CUPS-1.2 and system-config-printer-0.6.x, and so I will
make a test update package for system-config-printer for this problem.

Thanks for spotting it.

Note You need to log in before you can comment on or make changes to this bug.