This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 189097 - xenguest install fails - installation getting rpms from wrong url
xenguest install fails - installation getting rpms from wrong url
Status: CLOSED DUPLICATE of bug 183999
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-16 00:12 EDT by Deon George
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 16:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deon George 2006-04-16 00:12:36 EDT
Description of problem:
Running xenguest-install to install a guest using this command:

/usr/sbin/xenguest-install.py -n deon -f /home/admin/deon/deon.xen -r 256 -l
http://www.wurley.vpn/yum/Fedora/5/

fails with:
 raise Errors.RepoError, saved_repo_error, 
RepoError: failure: 
Fedora/RPMS/gjdoc-0.7.7-3.1.i386.rpm from
anaconda: [Errno 256] No more mirrors to try.

How reproducible:
Every time.

Steps to Reproduce:
1. Run installation, unselect all components (for a minimal install), fails
almost immediately when going to install packages.
  
Additional info:
My HTTP FC5 repository works fine for running systems with YUM - I used it to
upgrade from FC5test3 to FC5, and use it on other FC5 servers...

It looks like this:
lrwxrwxrwx 1 root root      24 Apr 16 12:29 disc1 -> /mnt/iso/FC-5-i386-disc1
lrwxrwxrwx 1 root root      24 Apr 16 12:29 disc2 -> /mnt/iso/FC-5-i386-disc2
lrwxrwxrwx 1 root root      24 Apr 16 12:30 disc3 -> /mnt/iso/FC-5-i386-disc3
lrwxrwxrwx 1 root root      24 Apr 16 12:30 disc4 -> /mnt/iso/FC-5-i386-disc4
lrwxrwxrwx 1 root root      24 Apr 16 12:30 disc5 -> /mnt/iso/FC-5-i386-disc5
drwxr-xr-x 2 root root     176 Apr 16 12:41 repodata
drwxr-xr-x 2 root root     904 Mar  1 00:55 RPMS.extras

With the ISO's automounted as required (this does work - I use "yum install" on
other systems all the time)

It seems that the installation wants to install gjdoc using this URL (taken from
the apache log):
disc1/Fedora/RPMS/gjdoc-0.7.7-3.1.i386.rpm, whereas the jgodc package is on
disc2? I dont understand how it could think it was on disc1, when createrepo
would have it listed on disc2?

I've re-run createrepo before starting the install just to be sure it was up to
date. (I've also confirmed looking that the createrepo files, that it has
location href=disc2...)
Comment 1 David Cantrell 2006-04-18 16:38:33 EDT

*** This bug has been marked as a duplicate of 183999 ***

Note You need to log in before you can comment on or make changes to this bug.