Bug 183999 - unable to install FC5T3 because tried to find rpm packages only in disc1 dir
unable to install FC5T3 because tried to find rpm packages only in disc1 dir
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
: 186003 189097 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 16:17 EST by Gabriel Ramirez
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 16:42:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gabriel Ramirez 2006-03-04 16:17:13 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. I tried to install FC5T3 from mounting the iso images in dir
/linux/fedora/core/4.92/i386/os and each iso image is a dir disc# where # is 1-5
2. when I try the htp install I give the server address and the path
/linux/fedora/core/4.92/i386/os first show me a dialog about Fedora dir not
found in os dir after clicking ok the program retry from dir disc1 and begin
downloading the stage2  image.
3. I remember from Fedora Core 4 it retied automatically without showing any dialog

4. the install halts because try to download the program w3m from dir disc1 when
it is found in disc3
  
Actual results:

unable to install FC5T3 from cd iso images mounted and shared via httpd server

Expected results:

a fresh and working install of FC5T3 this method worked for me in FC4

Additional info:
Comment 1 Gabriel Ramirez 2006-03-05 18:37:49 EST
the following is a addendum tyo the first comment:
- the machine is  booting from boot.iso in a cd
- the cds iso  images are mounted  via automount
- I select the option customize now

I tried the following:
1. creating a a dir in /linux/fedora/core/4.92/i386/ called cds and inside it
symlink to the disc# dir in dir os so I was able to create a repodata dir with
createrepo /linux/fedora/core/4.92/i386/cds
2. copy comps.xml to repodata dir and add his info to repomd.xml
3. so the contents of cds dir is disc1 disc2 disc3 disc3 disc4 disc5 repodata
4. actual result is anaconda will dowload some rpms , so is a little step
forward but later try to find a rpm in disc1 when the rpm phisically is in disc2

and I try another way

I delete the disc2 disc3 disc4 disc5 dirs and I symlink all rpms from os/disc2-5
/Fedora/RPMS/* to cds/disc1/Fedora/RPMS/.
the anaconda download a fe rpms but later complains about not finding disc3 dir

I combine the two solutions I create symlinks of disc2-5 and I symlink all rpms
into disc1/Fedora/RPMS
I success to install FC5T3 this way, but seems which the install program try to
find all rpms within disc1 and also in the other dirs disc2-5 in differents
steps of the installation

this method ( mounting the cd images without kludges) was/is working in Fedora
Core 4

maybe I'm overlooking something?

thanks
Comment 2 David Cantrell 2006-03-06 13:42:28 EST
No, you're not overlooking anything.  The install method you've described
stopped working post FC4.  It's on the list of things to take care of after FC5.
 The switch to yum for anaconda's package installation backend brought many
exciting and challenging problems, this one among them.

To do an HTTP installation now, you'll just need to have a directory with all of
the packages and correct repo data.  If you combine all of the packages from a
set of CDs to one directory, be sure to run createrepo to generate more or less
correct yum data.

Some time in the near future, the loopback mounting of ISO images for HTTP-based
installs should be working again.

Thanks again.
Comment 3 Paul Nasrat 2006-03-06 15:45:14 EST
FYI:

createrepo -g Fedora/base/comps.xml . 
Comment 4 Gabriel Ramirez 2006-03-06 22:41:05 EST
thanks for clarifying the current situation, and I will try that
Comment 5 Chris Lumens 2006-03-21 09:59:41 EST
*** Bug 186003 has been marked as a duplicate of this bug. ***
Comment 6 Gabriel Ramirez 2006-03-23 14:38:35 EST
today I tried mounting the DVD image (Fedora Core 5 Release, NOT test3) via a
loop device and exporting it via http and I did a minimal install from it
without problems thanks
Comment 7 David Cantrell 2006-04-18 16:38:57 EDT
*** Bug 189097 has been marked as a duplicate of this bug. ***
Comment 8 David Cantrell 2006-04-18 16:42:17 EDT
Changes committed to rawhide now.  Might change this around later because it's
not the best solution to this problem.  But it should work.

Note You need to log in before you can comment on or make changes to this bug.