Bug 1891267 - No such file or directory - after upgrading or reinstalling glibc
Summary: No such file or directory - after upgrading or reinstalling glibc
Keywords:
Status: CLOSED DUPLICATE of bug 1625584
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 32
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-25 00:35 UTC by Edward
Modified: 2020-10-26 09:09 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-26 09:09:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Edward 2020-10-25 00:35:05 UTC
Description of problem:

Upon upgrading or reinstalling the glibc package, dnf reports: No such file or directory.


Version-Release number of selected component (if applicable):

glibc-2.31-4.fc32.x86_64.rpm


How reproducible:

Upgrade or reinstall glibc package.


Actual results:

Downloading Packages:
glibc-2.31-4.fc32.x86_64.rpm                                                            9.6 MB/s | 3.5 MB     00:00    
------------------------------------------------------------------------------------------------------------------------
Total                                                                                   5.0 MB/s | 3.5 MB     00:00     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                1/1 
  Running scriptlet: glibc-2.31-4.fc32.x86_64                                                                       1/2 
  Reinstalling     : glibc-2.31-4.fc32.x86_64                                                                       1/2 
  Running scriptlet: glibc-2.31-4.fc32.x86_64                                                                       1/2 
  Cleanup          : glibc-2.31-4.fc32.x86_64                                                                       2/2 
  Running scriptlet: glibc-2.31-4.fc32.x86_64                                                                       2/2 
/var/tmp/rpm-tmp.83xRPu: line 5: /sbin/sln: No such file or directory

  Verifying        : glibc-2.31-4.fc32.x86_64                                                                       1/2 
  Verifying        : glibc-2.31-4.fc32.x86_64                                                                       2/2 

Reinstalled:
  glibc-2.31-4.fc32.x86_64                                                                                              

Complete!


Expected results:

Should upgrade or reinstall without error.


Additional info:

Comment 1 Florian Weimer 2020-10-26 09:09:28 UTC
This message is caused by the redhat-lsb package, not glibc.

*** This bug has been marked as a duplicate of bug 1625584 ***


Note You need to log in before you can comment on or make changes to this bug.