Bug 189194 - Issue with Large copies to External connected USB HDD.
Issue with Large copies to External connected USB HDD.
Status: CLOSED DUPLICATE of bug 189193
Product: Fedora
Classification: Fedora
Component: usbutils (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Woerner
Depends On:
  Show dependency treegraph
Reported: 2006-04-18 00:57 EDT by Anand Kulkarni
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-18 05:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Anand Kulkarni 2006-04-18 00:57:35 EDT
Description of problem:
system type : i386 / Compaq Presario V1039AP.
OS : Fedora Core 5 Release.
Kernel : Default Kernel that comes with FC5.

Problem description:
I have a complete iso collection of FC2 , FC3 , FC4 and FC5 [ Including 
RPMS,SRPMS] on my Local IDE HDD.Natuarally the overall size of this 
collection is very large.Recently i copied the whole folder of about 
15GB to an external USB-HDD [ VFAT/FAT32 Filesystem ]

once the whole stuff was copied and i tried few checksums i see that the 
ISO images copied to External HDD are actually changed.I burnt a few ISO
images from my external HDD to CDROM and not to my surprise i see that
those images were broken.

I noticed one thing.While copying the Large folder to EXT-HDD the USB
drive light would stop in between with out doing anything and my 
suspect here is the USB driver.there is some issue with I/O when it is 
doing in bulk.

Version-Release number of selected component (if applicable):
N/A [ FC5 default// out of intrest i tried this on my FC2,FC3,FC4;same 
     issue follows ]

How reproducible:

Steps to Reproduce:
1.Copy Large ISO image collections from Local IDE HDD [ EXT3 FS ] to an
  ExT HDD [ FAT32 FS ]
2.do a checksum of iamges copied to EXT HDD using either md5sum/sha1sum.
3.You can see the difference between checksums meaning copy was not 
  perfect ; I have tried to copy files upto 500MB successfully.but with
  sizes like 15GB it fails.
Actual results:
Try it yourself.If any doubts in above explanation contact me at 

Expected results:
I expect the CP to be perfect.something seems to be wrong.I doubt
this to be the USB Driver for Linux.

Additional info:
Comment 1 Thomas Woerner 2006-04-18 05:23:30 EDT

*** This bug has been marked as a duplicate of 189193 ***

Note You need to log in before you can comment on or make changes to this bug.