Bug 189193 - Issue with Large copies to External connected USB HDD.
Issue with Large copies to External connected USB HDD.
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 189194 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 00:57 EDT by Anand Kulkarni
Modified: 2015-01-04 17:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 18:18:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Kulkarni 2006-04-18 00:57:02 EDT
Description of problem:
========================
system type : i386 / Compaq Presario V1039AP.
OS : Fedora Core 5 Release.
Kernel : Default Kernel that comes with FC5.

Problem description:
======================
I have a complete iso collection of FC2 , FC3 , FC4 and FC5 [ Including 
RPMS,SRPMS] on my Local IDE HDD.Natuarally the overall size of this 
collection is very large.Recently i copied the whole folder of about 
15GB to an external USB-HDD [ VFAT/FAT32 Filesystem ]

once the whole stuff was copied and i tried few checksums i see that the 
ISO images copied to External HDD are actually changed.I burnt a few ISO
images from my external HDD to CDROM and not to my surprise i see that
those images were broken.

I noticed one thing.While copying the Large folder to EXT-HDD the USB
drive light would stop in between with out doing anything and my 
suspect here is the USB driver.there is some issue with I/O when it is 
doing in bulk.

Version-Release number of selected component (if applicable):
==============================================================
N/A [ FC5 default// out of intrest i tried this on my FC2,FC3,FC4;same 
     issue follows ]

How reproducible:
=================

Steps to Reproduce:
1.Copy Large ISO image collections from Local IDE HDD [ EXT3 FS ] to an
  ExT HDD [ FAT32 FS ]
2.do a checksum of iamges copied to EXT HDD using either md5sum/sha1sum.
3.You can see the difference between checksums meaning copy was not 
  perfect ; I have tried to copy files upto 500MB successfully.but with
  sizes like 15GB it fails.
  
Actual results:
==================
Try it yourself.If any doubts in above explanation contact me at 
akalexi312@yahoo.com

Expected results:
===================
I expect the CP to be perfect.something seems to be wrong.I doubt
this to be the USB Driver for Linux.

Additional info:
Comment 1 Thomas Woerner 2006-04-18 05:23:33 EDT
*** Bug 189194 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Woerner 2006-04-18 05:24:37 EDT
This is not a usbutils userland problem.

Assigning to kernel.
Comment 3 Pete Zaitcev 2006-05-16 21:21:46 EDT
It may be a bug, but in 95% cases it's something related to a hardware
malfunction (specifically, a bug in the enclosure firmware is the most
likely culprit). At this point, I can only suggest replacing the enclosure
with a unit of a different brand.
Comment 4 Dave Jones 2006-10-16 17:30:25 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 5 Dave Jones 2006-11-24 18:18:41 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug after installing all the
current updates, please reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.