Bug 1892775 - The job Extended: [Conformance][templates] templateinstance readiness test should report ready soon after all annotated objects are ready [Suite:openshift/conformance/parallel/minimal] is always failing
Summary: The job Extended: [Conformance][templates] templateinstance readiness test sh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.11.z
Assignee: Gabe Montero
QA Contact: wewang
URL:
Whiteboard:
: 1892548 1893657 (view as bug list)
Depends On:
Blocks: 1879445
TreeView+ depends on / blocked
 
Reported: 2020-10-29 16:02 UTC by Miheer Salunke
Modified: 2020-11-18 14:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-18 14:09:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25647 0 None closed Bug 1892775: disabling cakephp until upstream problem addressed: bugzilla 1891989 2020-12-02 03:49:08 UTC
Red Hat Bugzilla 1879445 0 urgent CLOSED SameSite hardening breaks sticky load balancing 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2020:5107 0 None None None 2020-11-18 14:10:44 UTC

Description Miheer Salunke 2020-10-29 16:02:52 UTC
Description of problem:

The job Extended: [Conformance][templates] templateinstance readiness test should report ready soon after all annotated objects are ready [Suite:openshift/conformance/parallel/minimal]  is always failing


Version-Release number of selected component (if applicable):
3.11

How reproducible:
Always

Steps to Reproduce:
1.go to https://github.com/openshift/origin/pull/25542
2. Add comment /retest
3.

Actual results:
These jobs are not passing

Expected results:
These jobs are passing



Additional info:

I see it is failing with "cannot find or open /opt/app-root/src/vendor/composer/tmp-8e8bda60677aaf48f974bbdd71542da6."

----
----
----

            Running post commit hook ...
            sh: cannot set terminal process group (-1): Inappropriate ioctl for device
            sh: no job control in this shell
            Exception: Plugin Migrations could not be found. in [/opt/app-root/src/vendor/cakephp/cakephp/src/Core/PluginCollection.php, line 127]
            error: build error: container "openshift_s2i-build_cakephp-mysql-example-1_e2e-test-templates-pmhkz_post-commit_bbe66c10" returned non-zero exit code: 244
          reason: Error



Actual log snip showing the issue

[It] should report ready soon after all annotated objects are ready [Suite:openshift/conformance/parallel/minimal]
  /tmp/openshift/build-rpms/rpm/BUILD/origin-3.11.0/_output/local/go/src/github.com/openshift/origin/test/extended/templates/templateinstance_readiness.go:125
STEP: instantiating the templateinstance
STEP: waiting for build and dc to settle

...
....

    State:      Terminated
      Reason:   Error
      Message:   cannot find or open /opt/app-root/src/vendor/composer/tmp-8e8bda60677aaf48f974bbdd71542da6.

    This most likely is due to a custom installer plugin not handling the returned Promise from the downloader
    See https://github.com/composer/installers/commit/5006d0c28730ade233a8f42ec31ac68fb1c5c9bb for an example fix
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Generating optimized autoload files
> Cake\Composer\Installer\PluginInstaller::postAutoloadDump
> App\Console\Installer::postInstall
Created `/opt/app-root/src/logs` directory
Created `/opt/app-root/src/tmp` directory
Created `/opt/app-root/src/tmp/cache` directory
Created `/opt/app-root/src/tmp/cache/models` directory
Created `/opt/app-root/src/tmp/cache/persistent` directory
Created `/opt/app-root/src/tmp/cache/views` directory
Created `/opt/app-root/src/tmp/sessions` directory
Created `/opt/app-root/src/tmp/tests` directory
Permissions set on /opt/app-root/src/tmp/cache
Permissions set on /opt/app-root/src/tmp/cache/models
Permissions set on /opt/app-root/src/tmp/cache/persistent
Permissions set on /opt/app-root/src/tmp/cache/views
Permissions set on /opt/app-root/src/tmp/sessions
Permissions set on /opt/app-root/src/tmp/tests
Permissions set on /opt/app-root/src/tmp
Permissions set on /opt/app-root/src/logs
No Security.salt placeholder to replace.
=> sourcing 20-copy-config.sh ...
---> 01:44:45     Processing additional arbitrary httpd configuration provided by s2i ...
=> sourcing 00-documentroot.conf ...
=> sourcing 50-mpm-tuning.conf ...
=> sourcing 40-ssl-certs.sh ...
Running post commit hook ...
sh: cannot set terminal process group (-1): Inappropriate ioctl for device
sh: no job control in this shell
Exception: Plugin Migrations could not be found. in [/opt/app-root/src/vendor/cakephp/cakephp/src/Core/PluginCollection.php, line 127]
error: build error: container "openshift_s2i-build_cakephp-mysql-example-1_e2e-test-templates-pmhkz_post-commit_bbe66c10" returned non-zero exit code: 244

      Exit Code:    1
      Started:      Thu, 29 Oct 2020 01:43:36 +0000
      Finished:     Thu, 29 Oct 2020 01:44:49 +0000
    Ready:          False
    Restart Count:  0

Comment 1 Andrew McDermott 2020-10-29 16:23:18 UTC
This is blocking https://bugzilla.redhat.com/show_bug.cgi?id=1879445

Recent runs in https://github.com/openshift/origin/pull/25542 show this to be consistently failing since 23rd October 2020.

Comment 3 Adam Kaplan 2020-10-29 18:33:47 UTC
This appears to be a regression with upstream CakePhP dependencies. Until that issue is resolved the test in question should be skipped.

Marking urgent blocker+ as this prevents 3.11 code from merging.

Comment 4 Gabe Montero 2020-11-02 13:15:24 UTC
*** Bug 1893657 has been marked as a duplicate of this bug. ***

Comment 5 Gabe Montero 2020-11-04 18:59:24 UTC
*** Bug 1892548 has been marked as a duplicate of this bug. ***

Comment 8 wewang 2020-11-13 06:04:07 UTC
Verified it in version: 
v3.11.318


Using php:7.2 to create build it's complete now

Steps: 
1. Using bc to test it
```
apiVersion: v1
kind: BuildConfig
metadata:
  name: myphp
  labels:
    app: myphp
  annotations:
    openshift.io/generated-by: OpenShiftWebConsole
spec:
  successfulBuildsHistoryLimit: 2
  source:
    type: Git
    git:
      uri: 'https://github.com/sclorg/cakephp-ex.git'
  strategy:
    type: Source
    sourceStrategy:
      from:
        kind: ImageStreamTag
        namespace: openshift
        name: 'php:7.2'
```

2. [wewang@wangwen ~]$ oc get builds
NAME      TYPE     FROM          STATUS     STARTED              DURATION
myphp-1   Source   Git@fddfeb3   Complete   About a minute ago   53s

Comment 9 wewang 2020-11-13 06:07:03 UTC
FYI, Hi, gabe the pr:https://github.com/openshift/origin/pull/25647, I think need to revert according comment8, how do you think?

Comment 10 Gabe Montero 2020-11-13 13:36:17 UTC
Hey Wen Wang

not sure I am able to entirely parse your #comment 9

but I can tell you that after we disabled  the test with PR 25647
we worked with upstream to fix cakephp, we re-enabled this test in 
question in 3.11 via 
was https://github.com/openshift/origin/pull/25661

we also backported several other e2e stability changes from 4.x to 3.11
in https://github.com/openshift/origin/pull/25661 as well

I think you can leave this BZ as verified

But if you #comment 8 was trying to ask about something else, let me 
know what specifics I am missing, and we'll go from there.

thanks

Comment 12 errata-xmlrpc 2020-11-18 14:09:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 3.11.318 bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5107


Note You need to log in before you can comment on or make changes to this bug.