Bug 18930 - gnorpm Segmentation Fault
gnorpm Segmentation Fault
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Elliot Lee
Dale Lovelace
:
: 18981 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 00:57 EDT by Jim Hayward
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 12:47:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Hayward 2000-10-12 00:57:48 EDT
After updating to the lastest gnorpm-0.95.1-3.i386.rpm if I right click on
any rpm file in the file manager and select "Show Info" the following error
message is displayed: Application "gnorpm" has crashed due to a fatal
error. Segmentation Fault. I did not experience this problem with the
version that shipped with RH7. Thanks
Comment 1 Alan Cox 2000-10-16 19:32:31 EDT
Reassigning back to other folk. I've verified that this seems to be some kind of
red hat specifc bug probably in librpm.
Comment 2 Alan Cox 2000-10-16 21:33:45 EDT
Moving to gnome-libs. Gnome-libs ships with its own old, broken buggy popt
implementation. This is a real mess. To make gnorpm work someone needs to fix
gnome-libs. Which probably means every gnome rpm package has to be recompiled
and replaced because someone wasnt on the ball and ended up with multiple
incompatible popt libraries in the tree
Comment 3 Jim Hayward 2000-10-17 03:21:57 EDT
Applied Alan's patch from 19220 and rebuilt the rpm, it seems to be working fine
now. Thanks
Comment 4 David Mason 2000-10-17 11:43:25 EDT
Owen, can you check into the popt in gnome-libs and how we can avoid this conflict
Comment 5 David Mason 2000-10-17 11:53:19 EDT
*** Bug 18981 has been marked as a duplicate of this bug. ***
Comment 6 Owen Taylor 2000-10-17 12:47:04 EDT
Assigned to Elliot, since he is popt/GNOME master. I'm not really
sure of the complete situation here - the popt version inside GNOME
is the canonical version for GNOME libraries, if current popt is
incompatible with this, we simply can't change it, because the
GNOME platform in 6.x/7.x is this version.

If linking to librpm also requires linking to current popt, I don't
know what the solution is; its definitely a problem. Recompiling all 
GNOME packages isn't an option; perhaps we can use a private gnome-libs 
version for gnorpm.


Comment 7 Alan Cox 2000-10-28 18:41:09 EDT
Chased this down in depth. Gnome libs is simply buggy. Its not the popt stuff
its that 7.0 was shipped with a horked gnome-libs. Fix gnome-libs and this
specific problem goes away

Note You need to log in before you can comment on or make changes to this bug.