Bug 18981 - another segfault in the new gnorpm
another segfault in the new gnorpm
Status: CLOSED DUPLICATE of bug 18930
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: David Mason
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 13:30 EDT by John Bollinger
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-16 21:35:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Bollinger 2000-10-12 13:30:20 EDT
After installing the gnorpm-0.95.1-3 update, whenever I select a package to
add from the GNOME RPM GUI I get an immediate segmentation fault, with a
message identical to that reported in bug #18930.  I can also report
duplicating bug #18930.
Comment 1 Alan Cox 2000-10-16 19:33:43 EDT
This does not happen with a correctly built gnorpm from Gnome CVS against
reference libraries. Reassigning to MSW to work out whats broken in the Red Hat
environment
Comment 2 Alan Cox 2000-10-16 20:14:12 EDT
RPM 4.0 builds its own libpopt, db1 and db3 that don't seem to 100% match. The
rpmlib is then
linked against these not the real ones that finally get used. This is totally
hosed. Someone please explain why rpm 4.0 in rpm format doesnt link with the
PROVIDED static db1/db3/popt libs from the rest of the distribution. That way
gnorpm might actually work
Comment 3 Alan Cox 2000-10-16 20:43:03 EDT
Ok its not popt. If I rebuild rpm4 with the proper popt there is no change. MSW
this is the startup trace I see

(gdb) b main
Breakpoint 1 at 0x8060ab9: file gnorpm.c, line 216.
(gdb) run
Starting program: /usr/src/redhat/BUILD/gnorpm-0.95.1/./gnorpm 

Breakpoint 1, main (argc=1, argv=0xbffffab4) at gnorpm.c:216
216	  DBHandle *dbhdl = NULL;
(gdb) b gdk_image_destroy
Breakpoint 2 at 0x4029c395
(gdb) run
The program being debugged has been started already.
Start it from the beginning? (y or n) n
Program not restarted.
(gdb) cont
Continuing.

Breakpoint 2, 0x4029c395 in gdk_image_destroy () from /usr/lib/libgdk-1.2.so.0
(gdb) where
#0  0x4029c395 in gdk_image_destroy () from /usr/lib/libgdk-1.2.so.0
(This is an attempt to destroy a NULL gdk_image)

#1  0x402a154f in gdk_rgb_allocate_images () from /usr/lib/libgdk-1.2.so.0
#2  0x402a1814 in gdk_rgb_init () from /usr/lib/libgdk-1.2.so.0
#3  0x402a5067 in gdk_rgb_get_visual () from /usr/lib/libgdk-1.2.so.0
#4  0x4010e683 in gdk_imlib_init () from /usr/lib/libgdk_imlib.so.1
#5  0x40095535 in gnome_init_cb () from /usr/lib/libgnomeui.so.32
#6  0x403b5c66 in invokeCallbacks () from /usr/lib/libgnomesupport.so.0
#7  0x403b5c2c in invokeCallbacks () from /usr/lib/libgnomesupport.so.0
#8  0x403b65e6 in poptGetNextOpt () from /usr/lib/libgnomesupport.so.0
#9  0x403ac759 in gnomelib_parse_args () from /usr/lib/libgnome.so.32
#10 0x4009571e in gnome_init_with_popt_table () from /usr/lib/libgnomeui.so.32
#11 0x8060b8c in main (argc=1, argv=0xbffffab4) at gnorpm.c:241
#12 0x40595a2c in __libc_start_main (main=0x8060ab0 <main>, argc=1, 
    ubp_av=0xbffffab4, init=0x805bd90 <_init>, fini=0x80e93dc <_fini>, 
    rtld_fini=0x4000d3c8 <_dl_fini>, stack_end=0xbffffaac)
    at ../sysdeps/generic/libc-start.c:111
(gdb) 
Comment 4 Alan Cox 2000-10-16 21:35:09 EDT
Gnome libs is shipped with an incorrect old version of popt. Gnome libs needs to
be fixed not gnorpm. This probably requires every gnome package is rebuilt to
fix this stupid error.
Comment 5 David Mason 2000-10-17 11:53:21 EDT

*** This bug has been marked as a duplicate of 18930 ***

Note You need to log in before you can comment on or make changes to this bug.