Bug 1893474 - firefox-82.0.2-1.fc33 breaks gmail and several extensions
Summary: firefox-82.0.2-1.fc33 breaks gmail and several extensions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 33
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1893432 1893446 1893496 1893548 1893578 1894168 1894688 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-31 20:45 UTC by Gerald Cox
Modified: 2020-11-18 20:23 UTC (History)
39 users (show)

Fixed In Version: firefox-82.0.2-3.fc33 firefox-82.0.2-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-05 01:03:31 UTC
Type: Bug


Attachments (Terms of Use)
about:support from firefox.txt (27.16 KB, text/plain)
2020-11-01 21:17 UTC, Stephen Benjamin
no flags Details

Description Gerald Cox 2020-10-31 20:45:43 UTC
Latest update breaks GMAIL.  Additionally FVD Speed Dial isn't working correctly - and this is what I've noticed after 5 minutes of use.  I've backed out.  This shouldn't have been pushed to stable so quickly.  GMAIL is a widely used application.

Comment 1 Erwan LE PENNEC 2020-10-31 21:07:36 UTC
I can confirm the Gmail issue.

Comment 2 Erwan LE PENNEC 2020-10-31 21:20:54 UTC
which occurs also with fc32.

Comment 3 Gerald Cox 2020-10-31 21:21:55 UTC
Here is the gmail error:
We’re sorry, but your account is temporarily unavailable. We apologize for the inconvenience and suggest trying again in a few minutes.You can view the G Suite Status Dashboard for the current status of the service.

If the issue persists, please visit the Help Center »

Try Again Sign Out

Hide Detailed Technical Info
Numeric Code: 9

Comment 4 J. Penala 2020-10-31 21:41:14 UTC
I can confirm the extension breakage, uBlock Origin stopped blocking anything with firefox-82.0.2-1.fc33, downgrading FF fixes it.  Also the 82.0.2 package from Mozilla works re uBlock Origin, so it seems to be specific to the Fedora FF build.

Comment 5 Gerald Cox 2020-11-01 19:50:17 UTC
*** Bug 1893548 has been marked as a duplicate of this bug. ***

Comment 6 Gerald Cox 2020-11-01 19:55:01 UTC
*** Bug 1893432 has been marked as a duplicate of this bug. ***

Comment 7 Martin Stransky 2020-11-01 20:48:50 UTC
I'm unable to reproduce on Fedora 32 - may it be F33 specific? Also:

- Can you check upstream builds if you see the same problem? [1] 
- Can you attach/submit any crash report? [2]

Thanks.

[1] https://fedoraproject.org/wiki/How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Testing_Mozilla_binaries
[2] https://fedoraproject.org/wiki/How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Collect_information_for_a_bug_report

Comment 8 Martin Stransky 2020-11-01 20:53:06 UTC
*** Bug 1893496 has been marked as a duplicate of this bug. ***

Comment 9 Martin Stransky 2020-11-01 20:54:10 UTC
*** Bug 1893446 has been marked as a duplicate of this bug. ***

Comment 10 Stephen Benjamin 2020-11-01 21:17:13 UTC
Created attachment 1725609 [details]
about:support from firefox.txt

Comment 11 Stephen Benjamin 2020-11-01 21:18:21 UTC
I did not see the same behavior on the upstream builds. I've attached my about:support. There are no crashes, random stuff just doesn't work, for example FastMail web site and the LastPass add-on.

Comment 12 Martin Stransky 2020-11-01 21:28:49 UTC
Do you have anything in your browser console [1]? Any complains about addon/permissions or so?

[1] In upper menu go to Tools -> Web Developer -> Browser Console

Comment 13 Andreas M. Kirchwitz 2020-11-01 21:53:25 UTC
(Just for the records, similar comments in other related tickets.)

"firefox-82.0-5" is the last build that worked fine (on both, FC32 and FC33).

Then something changed...

Starting with build "firefox-82.0-6" (or whatever is available for FC32 + FC33), Firefox breaks also Telegram (web.telegram.org), not just Gmail (mail.google.com). Shift-Reload solves the issue in both cases, but it occurs again every time the web page is loaded. It doesn't help to clear cookies and cache, it may work for some time, but the problem eventually comes back.

To see the problem, you must have been logged in previously on Telegram or Gmail. (I guess there will be some session cookies.)


If you then go to "web.telegram.org" (with that stored session information), a blank page appears. Always. Shift-Reloads makes the page load as it should have in the first place.

Browser console (Telegram):
SecurityError: Permission denied to access property "windowGlobalChild" on cross-origin object ExtensionUtils.jsm:114
SecurityError: Permission denied to access property "removeEventListener" on cross-origin object ExtensionCommon.jsm:414


Gmail behaves similar. Sometimes you see your Inbox, but most of the time you get this error message "We’re sorry, but your account is temporarily unavailable." Shift-Reloads makes the page load as it should. Funny thing, hit Reload (without Shift) again, you get the Error message. Shift-Reloads solves it again.

Browser console (Gmail):
Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
SecurityError: Permission denied to access property "windowGlobalChild" on cross-origin object ExtensionUtils.jsm:114
SecurityError: Permission denied to access property "removeEventListener" on cross-origin object ExtensionCommon.jsm:414
NS_ERROR_INVALID_CONTENT_ENCODING: Component returned failure code: 0x804b001b (NS_ERROR_INVALID_CONTENT_ENCODING) [nsIStreamListener.onDataAvailable] network-response-listener.js:571


Though, I have no issues detected with add-ons (i.e. uBlock Origin, Enhancer for YouTube). And they don't affect the problem reported here.

Comment 14 Chris Murphy 2020-11-02 00:28:26 UTC
Related bug 1893578, possible dup (I made that one lastpass specific).

Comment 15 Gerald Cox 2020-11-02 02:32:29 UTC
(In reply to Martin Stransky from comment #7)
> I'm unable to reproduce on Fedora 32 - may it be F33 specific? Also:
> 
> - Can you check upstream builds if you see the same problem? [1] 
> - Can you attach/submit any crash report? [2]
> 
> Thanks.
> 
> [1]
> https://fedoraproject.org/wiki/
> How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Testing_Mozilla_binaries
> [2]
> https://fedoraproject.org/wiki/
> How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Collect_information_for_a_b
> ug_report


No longer running F32 so can't report on that.

[1] Problem doesn't occur with upstream version, nor upstream Nightly.
[2] Crash doesn't occur.  Only receive Temporary Error Message and speeddial issues
as noted above. 

Comment #10 provided other info requested.

Comment 16 Martin Stransky 2020-11-02 09:27:28 UTC
*** Bug 1893578 has been marked as a duplicate of this bug. ***

Comment 17 Martin Stransky 2020-11-02 09:58:56 UTC
Okay, thanks for the info.

I tested latest Firefox 88.0.2 on Fedora 33 but I can't reproduce that - Gmail works, mBlock origin works too so I'd need to diagnose it from the logs.
Can you run Upstream Firefox and Fedora Firefox and compare output from Browser console?
Also can you install firefox-x11 package and try Firefox X11?

Thanks.

Comment 18 Marko Bevc 2020-11-02 10:14:15 UTC
Martin it usually happen only when restoring tabs in my case - so if you close and open FF. When it restores previously opened tabs GMail is not working until hard refresh Ctrl+F5. Not sure if it's related to Wayland as I'm using X11 here.

Comment 19 Martin Stransky 2020-11-02 10:20:46 UTC
Yes, I can reproduce it now, it throws:

NS_ERROR_INVALID_CONTENT_ENCODING: Component returned failure code: 0x804b001b (NS_ERROR_INVALID_CONTENT_ENCODING) [nsIStreamListener.onDataAvailable] 3 network-response-listener.js:571
    onInputStreamReady resource://devtools/server/actors/network-monitor/network-response-listener.js:571

Comment 20 J. Penala 2020-11-02 10:42:19 UTC
After some tries I've noticed that uBlock works with the default blocklist subscriptions, but as soon as I add extra lists, like all the adguard ones, uBlock stops working. 


This is the output from console:

[Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIAppStartup.secondsSinceLastOSRestart]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: resource:///modules/BrowserGlue.jsm :: _collectStartupConditionsTelemetry :: line 1743"  data: no] BrowserGlue.jsm:1743:9
Unknown category for SetEventRecordingEnabled: fxmonitor
TypeError: PrecompiledScript.executeInGlobal: Argument 1 is not an object. ExtensionContent.jsm:568:25
Cc['@mozilla.org/toolkit/glean;1'] is undefined BrowserGlue.jsm:2603
IndexedDB UnknownErr: ActorsParent.cpp:547
UnknownError: The operation failed for reasons unrelated to the database itself and not covered by any other error code. ExtensionStorageIDB.jsm:831
uncaught exception: null
IndexedDB UnknownErr: ActorsParent.cpp:547
UnknownError: The operation failed for reasons unrelated to the database itself and not covered by any other error code. ExtensionStorageIDB.jsm:831
uncaught exception: null
IndexedDB UnknownErr: ActorsParent.cpp:547
UnknownError: The operation failed for reasons unrelated to the database itself and not covered by any other error code. ExtensionStorageIDB.jsm:831
uncaught exception: null
IndexedDB UnknownErr: ActorsParent.cpp:547
UnknownError: The operation failed for reasons unrelated to the database itself and not covered by any other error code. ExtensionStorageIDB.jsm:831
uncaught exception: null
IndexedDB UnknownErr: ActorsParent.cpp:547
UnknownError: The operation failed for reasons unrelated to the database itself and not covered by any other error code. ExtensionStorageIDB.jsm:831
uncaught exception: null
debuggee 'resource://devtools/shared/base-loader.js:289' would run



I don't see those with the Mozilla FF package.

Comment 21 Martin Stransky 2020-11-02 11:35:15 UTC
Hm, I also get "Error: Incorrect contents fetched, please reload" in content console.

Comment 22 Martin Stransky 2020-11-02 12:24:35 UTC
Seems to be related to Firefox packaging, Fedora build fired directly from build dir does not exhibit such issue.

Comment 23 Petr Sklenar 2020-11-02 12:44:54 UTC
I have f32 + firefox-82.0.2-1.fc32.x86_64
no ublock  here and there is same issue with gmail account.


firefox --safe-mode # show the same

Comment 24 Lukas Zapletal 2020-11-02 12:52:33 UTC
Suffering from the same, luckily upgraded only on my "backup" laptop.

Comment 25 Nadav Har'El 2020-11-02 14:04:30 UTC
Can confirm exactly the same bug on firefox-82.0.2-1.fc32.x86_64 on Fedora 32.
The bug is not specific to gmail - I have exactly the same problem on deezer.com: When I click play on a song, an error message pops up. If I tell Firefox to remove all the cookies and data from "deezer.com", it starts working again. However, if I close the tab and open another tab for deezer.com, the problem starts again and I need to remove the cookies and data yet again.

Upstream issue (with no solutions or ideas): https://bugzilla.mozilla.org/show_bug.cgi?id=1586047

Comment 26 Nadav Har'El 2020-11-02 14:12:19 UTC
(In reply to Andreas M. Kirchwitz from comment #13)
> Shift-Reload solves the issue in both cases, but it
> occurs again every time the web page is loaded.

This is an excellent workaround and works very well until this bug is fixed. When you see a malfunctioning page (gmail.com, deezer.com, etc.), press Shift-Reload and it will start working.

Comment 27 alexkforte 2020-11-02 15:37:41 UTC
WhatsApp Web is also broken on Firefox, "shift + reload" temporarily fixes it.

Comment 28 jaoppoucci 2020-11-02 23:15:44 UTC
Adblock Plus won't remember any of it's settings (after closing browser) in Fedora 32 since upgrading to this build of Firefox.

Comment 29 Martin Stransky 2020-11-03 09:16:10 UTC
Hm, I can't reproduce that with gmail any more, looking for new reproducer.

Comment 30 Andreas M. Kirchwitz 2020-11-03 10:58:38 UTC
Just tried Gmail, worked fine, even for several calls. Started to type my text here in that comment, and just for a final verification, switched back to Gmail, one last reload ... and then again it failed to work. Temporary Error every single time now. Looks like it just needed some time to pass, before the bug presents itself again. However, Gmail never reliably showed the issue. Always worked sometimes for some magical reason.

Where it never worked the first time for me, that is https://web.telegram.org/ (like Gmail, must be logged in from a previous session). Fails every time.

Others have reported Deezer and Spotify, but for unknown reasons both work 100% fine for me. Don't know what makes my PC different from others. (I'm using the "free" account plan on both, don't have paid subscriptions there.)

I like to point out again that the bug started between builds "firefox-82.0-5" and "firefox-82.0-6". The ChangeLog lists "Enable LTO" as the only major difference between those builds. If that might be of any help.

On FC32, it was very obvious, up until "firefox-82.0-5" all was fine, and with "firefox-82.0-6" and all further builds the problem showed up.

On FC33, there was a long series of failed builds after "firefox-82.0-5", finally "firefox-82.0.2-1" was successful, and it showed the problem.

Comment 31 Martin Stransky 2020-11-03 12:05:31 UTC
I think I have a new reproducer - kfc.cz site. Fails to load with error message of failed web workers...so investigating there.

Comment 32 Timothy Redaelli 2020-11-03 13:39:21 UTC
(In reply to Andreas M. Kirchwitz from comment #30)
> Just tried Gmail, worked fine, even for several calls. Started to type my
> text here in that comment, and just for a final verification, switched back
> to Gmail, one last reload ... and then again it failed to work. Temporary
> Error every single time now. Looks like it just needed some time to pass,
> before the bug presents itself again. However, Gmail never reliably showed
> the issue. Always worked sometimes for some magical reason.
> 
> Where it never worked the first time for me, that is
> https://web.telegram.org/ (like Gmail, must be logged in from a previous
> session). Fails every time.
> 
> Others have reported Deezer and Spotify, but for unknown reasons both work
> 100% fine for me. Don't know what makes my PC different from others. (I'm
> using the "free" account plan on both, don't have paid subscriptions there.)
> 
> I like to point out again that the bug started between builds
> "firefox-82.0-5" and "firefox-82.0-6". The ChangeLog lists "Enable LTO" as
> the only major difference between those builds. If that might be of any help.
> 
> On FC32, it was very obvious, up until "firefox-82.0-5" all was fine, and
> with "firefox-82.0-6" and all further builds the problem showed up.
> 
> On FC33, there was a long series of failed builds after "firefox-82.0-5",
> finally "firefox-82.0.2-1" was successful, and it showed the problem.

Yes, it's LTO.

I re-built Firefox (with mock) without lto enabled and it works without any problem

Comment 33 Martin Stransky 2020-11-03 17:59:14 UTC
Thanks, I'll fire new builds without LTO. Would be great to find what's the actual problem anyway.

Comment 34 Lucas 2020-11-03 20:28:55 UTC
I am having the same issue re:Gmail. FF82, Fedora 33. I downgraded to FF81 and things are working again

Comment 35 Martin Stransky 2020-11-03 21:15:43 UTC
*** Bug 1894168 has been marked as a duplicate of this bug. ***

Comment 36 Martin Stransky 2020-11-03 21:18:27 UTC
firefox-82.0.2-3.* builds from https://koji.fedoraproject.org/koji/packageinfo?packageID=37 should fix that.

Comment 37 Chris Murphy 2020-11-04 02:23:57 UTC
firefox-82.0.2-3.fc33.x86_64.rpm has fixed this for me.

Comment 38 J. Penala 2020-11-04 05:40:10 UTC
Latest koji build works for me, thank you!

Comment 39 Martin Wolf 2020-11-04 07:36:36 UTC
@stransky@redhat.com
your new build also fixes whatsapp web for me.

Comment 40 Fedora Update System 2020-11-04 07:41:31 UTC
FEDORA-2020-1c93247d99 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-1c93247d99

Comment 41 Fedora Update System 2020-11-04 07:41:32 UTC
FEDORA-2020-b3abc18551 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b3abc18551

Comment 42 Martin Stransky 2020-11-04 07:43:37 UTC
Timothy, Thanks a lot for your hint! New builds are in updates now.

Comment 43 Fedora Update System 2020-11-05 01:03:31 UTC
FEDORA-2020-1c93247d99 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 44 Fedora Update System 2020-11-05 01:04:24 UTC
FEDORA-2020-b3abc18551 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 45 Fedora Update System 2020-11-05 02:13:17 UTC
FEDORA-2020-fc8baf8df4 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-fc8baf8df4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-fc8baf8df4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 46 ffbeacc 2020-11-05 21:16:02 UTC
*** Bug 1894688 has been marked as a duplicate of this bug. ***

Comment 47 Fedora Update System 2020-11-06 02:33:50 UTC
FEDORA-2020-d9020b3054 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-d9020b3054`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d9020b3054

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 48 Martin Stransky 2020-11-18 20:23:37 UTC
The gcc crash is still here although I don't know if it's related. I filed https://bugzilla.redhat.com/show_bug.cgi?id=1899294 for it.


Note You need to log in before you can comment on or make changes to this bug.