Bug 189354 - SELinux targeted policy breaks metacity
SELinux targeted policy breaks metacity
Status: CLOSED DUPLICATE of bug 188401
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Russell Coker
:
: 186108 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 10:20 EDT by W. Michael Petullo
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 10:29:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2006-04-19 10:20:37 EDT
Description of problem:
Metacity will not run when SELinux is enforcing its targeted policy.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.2.32-2

How reproducible:
Every time

Steps to Reproduce:
Set SELinux to enforce its targeted policy.  Try to run metacity.
  
Actual results:
[user@machine ~]$ metacity
metacity: error while loading shared libraries: libGL.so.1: cannot enable
executable stack as shared object requires: Permission denied

type=AVC msg=audit(1145477317.379:125): avc:  denied  { execstack } for 
pid=3009 comm="metacity" scontext=user_u:system_r:unconfined_t:s0
tcontext=user_u:system_r:unconfined_t:s0 tclass=process
type=SYSCALL msg=audit(1145477317.379:125): arch=40000003 syscall=125 success=no
exit=-13 a0=bfcac000 a1=1000 a2=1000007 a3=fffff000 items=0 pid=3009 auid=501
uid=501 gid=501 euid=501 suid=501 fsuid=501 egid=501 sgid=501 fsgid=501
comm="metacity" exe="/usr/bin/metacity"

lrwxrwxrwx  root     root     system_u:object_r:lib_t         
/usr/lib/libGL.so.1 -> libGL.so.1.2
-rwxr-xr-x  root     root     system_u:object_r:textrel_shlib_t
/usr/lib/libGL.so.1.2


Expected results:
Metacity should run.

Additional info:
Comment 1 Daniel Walsh 2006-04-19 10:29:20 EDT

*** This bug has been marked as a duplicate of 188401 ***
Comment 2 Daniel Walsh 2006-04-20 11:09:40 EDT
*** Bug 186108 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.