Bug 188401 - metacity no longer starts with selinux in enforcing mode
metacity no longer starts with selinux in enforcing mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
X/OpenGL Maintenance List
:
: 188069 188295 189354 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 23:19 EDT by Christopher Aillon
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: mesa-libGL-6.5-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 14:32:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Aillon 2006-04-08 23:19:38 EDT
% metacity &
% metacity: error while loading shared libraries: libGL.so.1: cannot enable
executable stack as shared object requires: Permission denied

[1]  + exit 127   metacity
%


Version-Release number of selected component (if applicable):

metacity-2.15.0-3.x86_64
selinux-policy-2.2.29-4.noarch

How reproducible: ALWAYS

Steps to Reproduce:
1. Enable selinux
2. Start metacity

  
Actual results:
It fails to load, with selinux avc messages denying it


Expected results:
Sexy window management

Additional info:

Apr  8 19:12:07 anduin kernel audit(1144537927.494:219)  avc: denied  {
execstack }  for pid=3006 comm="metacity"
scontext=user_u:system_r:unconfined_t:s0
tcontext=user_u:system_r:unconfined_t:s0 tclass=process
Comment 1 Christopher Aillon 2006-04-10 15:46:52 EDT
Appears to be a mesa issue.  I think this can be solved by adding 

   .section .note.GNU-stack, "", @progbits ; .previous

to the x86-64 assembly code generated in src/mesa/glapi/gl_x86-64_asm.py
Comment 2 Christopher Aillon 2006-04-11 14:32:15 EDT
krh added the above bits and this is now fixed in today's mesa update.
Comment 3 Christopher Aillon 2006-04-11 14:33:06 EDT
*** Bug 188069 has been marked as a duplicate of this bug. ***
Comment 4 Christopher Aillon 2006-04-11 14:33:26 EDT
*** Bug 188295 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Walsh 2006-04-19 10:29:43 EDT
*** Bug 189354 has been marked as a duplicate of this bug. ***
Comment 6 W. Michael Petullo 2006-04-30 13:27:08 EDT
Confirmed fixed with:

mesa-libGL-6.5-4
selinux-policy-targeted-2.2.35-2

Note You need to log in before you can comment on or make changes to this bug.