Bug 189386 - Chinese locale set incorrectly by system-config-language
Chinese locale set incorrectly by system-config-language
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-language (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
: 189201 189203 (view as bug list)
Depends On:
Blocks: 208407
  Show dependency treegraph
 
Reported: 2006-04-19 12:53 EDT by Charles Rose
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2006-0737
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 08:57:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Rose 2006-04-19 12:53:41 EDT
(From Issue Tracker 91839)
Description of problem:
When Chinese (Simplified) is selected as one among multiple locales during
install, and set as the default locale, anaconda sets up /etc/sysconfig/i18n
correctly with the LANG variable set to "zh_CN.UTF-8".

When we use system-config-language to change the default locale to any other
language and back to Chinese (Simplified), it sets the LANG variable to
"zh_CN.GB18030" instead of "zh_CN.UTF-8" (which is the correct locale as
mentioned by the RHEL4 Release Notes). This causes garbled characters to be
displayed while in the Simplified Chinese locale when the GUI is redirected via
Dell's new Remote Access Card.

Version-Release number of selected component (if applicable):
system-config-language-1.1.8-1

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4 Update3 with Simplified Chinese as one of the locales. Set it
as the default locale
2. Postinstall, check /etc/sysconfig/i18n ; LANG=zh_CN.UTF-8
3. run system-config-language to change the default locale to some other
language and back to simplified chinese.
4. Now check /etc/sysconfig/i18n ; LANG=zh_CN.GB18030
  
Actual results:
LANG in /etc/sysconfig/i18n should be set to "zh_CN.UTF-8" when
system-config-language is used to set the locale to simplified chinese

Expected results:
LANG in /etc/sysconfig/i18n is set to "zh_CN.GB18030" when
system-config-language is used to set the locale to simplified chinese

Additional info:

/usr/share/system-config-language/language_backend.py contains the zh_CN.GB18030
hardcoded which is apparently a hack.
Comment 1 Bastien Nocera 2006-04-25 06:01:19 EDT
*** Bug 189203 has been marked as a duplicate of this bug. ***
Comment 2 Bastien Nocera 2006-04-25 06:01:26 EDT
*** Bug 189201 has been marked as a duplicate of this bug. ***
Comment 15 Charles Rose 2006-10-26 10:47:51 EDT
Bug 208407 claims to fix the RHEL 5 manifestation of this issue. Does the same
fix hold good for this as well? We were expecting this fix in RHEL4.5 fasttrack.
Comment 17 Paul Nasrat 2006-11-10 07:08:02 EST
Commited fix as patch to package and built
Comment 22 Samuel Benjamin 2006-11-21 11:40:53 EST
Another request from Dell to pull this into FASTRACK. I see it is already
fastrack ACKED and MODIFIED. Can Red Hat provide an estimate on when we can get
this fix released ?

--------------------
Charles Rose wrote :

Can we expect this as a fasttrack (as discussed) now that it has a fix?

18 April 2007 (RHEL 4.5) is about 5 months away, and we definitely do
not want to wait till then.

Thanks,
Charles

Comment 24 Red Hat Bugzilla 2006-11-22 08:57:20 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0737.html

Note You need to log in before you can comment on or make changes to this bug.