Bug 18944 - Intallation error - Exceptional condition
Intallation error - Exceptional condition
Status: CLOSED DUPLICATE of bug 18031
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 06:35 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-27 16:02:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-12 06:35:55 EDT
I'm a Linux novice, upgrading 6.2 to 7 during the install I got the error 
below which the installer suggested was a bug. I can't tell if it's 
similar to the reported anaconda errors or not.

ERROR MESSAGE

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1543, in 
doInstall
    self.instCallback, p)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1298, in 
instCallback
    self.rpmFD = os.open(fn, os.O_RDONLY)
OSError: [Errno 2] No such file or 
directory: '/mnt/source/RedHat/RPMS/setup-2.3.4-1.noarch.rpm'

Local variables in innermost frame:
fn: /mnt/source/RedHat/RPMS/setup-2.3.4-1.noarch.rpm
total: 0
self: <todo.ToDo instance at 84a1280>
h: <header object at 8968430>
amount: 0
intf: <progress_gui.InstallProgressWindow instance at 84ed2b8>
what: 2

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>
Comment 1 Michael Fulbright 2000-10-18 17:59:35 EDT
Did you write this CDROM yourself?
Comment 2 Need Real Name 2000-10-19 04:40:14 EDT
Yes, The Cd's were ftp'd from 
http://www.mirror.ac.uk/sites/ftp.redhat.com/pub/redhat/redhat-7.0/iso/

7.0-i386-disc1.iso 670564352 and 7.0-i386-disc2.iso 676231168

I then burned them myself.
Comment 3 Michael Fulbright 2000-10-27 16:02:42 EDT
Please try downloading the images from a different site (be sure to use binary
mode transfers).

It looks like you images were corrupted.

*** This bug has been marked as a duplicate of 18031 ***

Note You need to log in before you can comment on or make changes to this bug.