Bug 189497 - Xen UUIDs are available from Dom0, but not from DomU
Xen UUIDs are available from Dom0, but not from DomU
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Markus Armbruster
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 11:33 EDT by Robin Norwood
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 11:46:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robin Norwood 2006-04-20 11:33:09 EDT
Xen provides a UUID for running domains, but this UUID is only available from
dom0, not domU.  Management applications (such as RHN) need a way to associate
the domain attached to a given dom0 with the running instance.

The method for paravirtualized hosts as discussed will probably be to expose the
UUID via /proc.  Fully virtualized hosts will need to use a different method, so
another bug will be filed for them.
Comment 1 Robin Norwood 2006-04-20 11:36:51 EDT
See bug #189498 for fully virtualized domains.
Comment 2 Mark McLoughlin 2006-08-01 09:53:29 EDT
Looks like /sys/hypervisor/uuid exists in kernel-xen-2.6.17-1.2488.fc6

Note You need to log in before you can comment on or make changes to this bug.