Bug 189502 - smbclient locks up Active Directory account
smbclient locks up Active Directory account
Status: CLOSED DUPLICATE of bug 176649
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 12:30 EDT by Steve Isaacson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-23 19:05:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smbclient run with debug=10 (12.80 KB, text/plain)
2006-04-20 12:46 EDT, Steve Isaacson
no flags Details

  None (edit)
Description Steve Isaacson 2006-04-20 12:30:55 EDT
Description of problem:

While running smbclient that came with fc4, this command ran fine, day in and
day out from a cronjob:

smbclient $server_service -A $authfile -Tc $DIR/$dir.tar $dir

It simply connects to a Windows machine and tars up the directory.

After upgrading to fc5, the command would cause the Active Directory account to
be LOCKED OUT. Unfortunately I don't know anything about Active Directory so I
can't tell you what that means. What I know is that I would have to call the IT
department, they would confirm that the account is LOCKED, and then they would
UNLOCK it. Presumably the effect is the same as if someone attempted to log in
multiple times with the wrong password.


Version-Release number of selected component (if applicable):

smbclient: Version 3.0.22-1.fc5
Active Directory: OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]

How reproducible:

Easy to reproduce. Over and over. Just run the command above.



Steps to Reproduce:
1. Run a command similar to this:

smbclient $server_service -A $authfile -Tc $DIR/$dir.tar $dir

Actual results:

You receive an UNABLE TO CONNECT ACCOUNT IS LOCKED error message.
  


Expected results:

For smblient to connect and create tar file.

Additional info:

Connecting manually and issuing the tar command works fine.
I worked around the bug by writing a script that uses Expect to connect
and then do the tar.
Comment 1 Steve Isaacson 2006-04-20 12:46:10 EDT
Created attachment 128044 [details]
smbclient run with debug=10

Output from running smbclient command with debug turned on. Error message
displayed at end of file.
Comment 2 Guenther Deschner 2007-03-14 11:29:52 EDT
We need to see the contents of your $authfile (gray out the password of course)
for reproduction.
Comment 3 Steve Isaacson 2007-03-14 22:32:05 EDT
I no longer have access to the file. Sorry.
Comment 4 Simo Sorce 2007-03-23 18:44:49 EDT
I reproduced the bug, need to investigate more, thanks for reporting.
Comment 5 Simo Sorce 2007-03-23 19:05:08 EDT

*** This bug has been marked as a duplicate of 176649 ***

Note You need to log in before you can comment on or make changes to this bug.