Bug 1896390 - bubblemail fails to build with Python 3.10: free(): invalid pointer
Summary: bubblemail fails to build with Python 3.10: free(): invalid pointer
Keywords:
Status: CLOSED DUPLICATE of bug 1904379
Alias: None
Product: Fedora
Classification: Fedora
Component: bubblemail
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert-André Mauchin 🐧
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1904379
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-10 13:10 UTC by Tomáš Hrnčiar
Modified: 2021-01-09 10:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-09 10:54:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-10 13:10:05 UTC
bubblemail fails to build with Python 3.10.0a2.

Writing /builddir/build/BUILDROOT/bubblemail-1.3-1.fc34.x86_64/usr/lib/python3.10/site-packages/bubblemail-1.3-py3.10.egg-info
free(): invalid pointer

RPM build errors:
/var/tmp/rpm-tmp.q5Ohhw: line 39:    90 Aborted                 (core dumped) CFLAGS="${CFLAGS:-${RPM_OPT_FLAGS}}" LDFLAGS="${LDFLAGS:-${RPM_LD_FLAGS}}" /usr/bin/python3 setup.py install -O1 --skip-build --root /builddir/build/BUILDROOT/bubblemail-1.3-1.fc34.x86_64
error: Bad exit status from /var/tmp/rpm-tmp.q5Ohhw (%install)
    Bad exit status from /var/tmp/rpm-tmp.q5Ohhw (%install)

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01756968-bubblemail/

For all our attempts to build bubblemail with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/bubblemail/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-10 13:33:35 UTC
This one is weird :/

Comment 2 Alexander Ploumistos 2020-11-10 13:44:02 UTC
I am going to report this upstream, but it could indicate a bug with 3.10.

Comment 3 Alexander Ploumistos 2020-11-10 14:00:34 UTC
Filed
https://framagit.org/razer/bubblemail/-/issues/15

Comment 4 Miro Hrončok 2020-11-19 12:36:36 UTC
I suspect PIL (pillow) is broken. See also bz1899498 and bz1898977.

Comment 5 Miro Hrončok 2021-01-09 10:54:48 UTC

*** This bug has been marked as a duplicate of bug 1904379 ***


Note You need to log in before you can comment on or make changes to this bug.