Bug 1899498 - python-qrcode fails to build with Python 3.10: free(): invalid pointer
Summary: python-qrcode fails to build with Python 3.10: free(): invalid pointer
Keywords:
Status: CLOSED DUPLICATE of bug 1904379
Alias: None
Product: Fedora
Classification: Fedora
Component: python-qrcode
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1904379
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-19 12:22 UTC by Tomáš Hrnčiar
Modified: 2021-01-09 10:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-09 10:55:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-19 12:22:19 UTC
python-qrcode fails to build with Python 3.10.0a2.

+ for m in $modules
+ /usr/bin/python3 -c 'import qrcode.image.pil'
free(): invalid pointer

RPM build errors:
/var/tmp/rpm-tmp.mJ26Ax: line 40:   247 Aborted                 (core dumped) /usr/bin/python3 -c "import $m"
error: Bad exit status from /var/tmp/rpm-tmp.mJ26Ax (%check)
    Bad exit status from /var/tmp/rpm-tmp.mJ26Ax (%check)

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01773372-python-qrcode/

For all our attempts to build python-qrcode with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-qrcode/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-19 12:35:38 UTC
Tomáš, I suspect PIL (pillow) is broken. See also bz1898977 and bz1896390.

Comment 2 Michel Alexandre Salim 2020-11-20 20:29:03 UTC
(In reply to Miro Hrončok from comment #1)
> Tomáš, I suspect PIL (pillow) is broken. See also bz1898977 and bz1896390.

so PIL itself compiles, just its dependents are broken?

Comment 4 Miro Hrončok 2021-01-09 10:55:35 UTC

*** This bug has been marked as a duplicate of bug 1904379 ***


Note You need to log in before you can comment on or make changes to this bug.