Bug 189708 - mkinitrd does not work with 2.6.17-pre2
mkinitrd does not work with 2.6.17-pre2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
: 196556 196626 205009 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-23 12:40 EDT by Dirk Nehring
Modified: 2008-01-08 21:54 EST (History)
5 users (show)

See Also:
Fixed In Version: mkinitrd-5.0.32-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 21:54:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Nehring 2006-04-23 12:40:10 EDT
Description of problem:
Booting a custom kernel up to 2.6.16.9 works flawlessly, since 2.6.17-pre2
(first tested kernel), booting failed in initrd. Last seen command on screen:
"Creating block device nodes." I assume "mkblkdevs" is not compatible with the
/proc and /sys changes in 2.6.17.


Version-Release number of selected component (if applicable):
mkinitrd-5.0.32
mkinitrd-5.0.34

How reproducible:


Steps to Reproduce:
1. Install pristine 2.6.17-pre2 kernel (with initrd aktived)
2. boot
  
Actual results:
Hangs in mkblkdevs

Expected results:
boot

Additional info:
Comment 1 Peter Jones 2006-08-16 17:32:25 EDT
I can't reproduce this.  Is it still a problem for you?
Comment 2 Dirk Nehring 2006-08-16 17:41:48 EDT
Yes, it is a problem of the device-mapper devices for hda. My solution was to
drop the device-mapper interfaces and using hda directly, since I'm not using
any RAID option. I assume the correct devicenames are not generated automatically.

Dirk
Comment 3 Ronald Cole 2006-08-27 17:41:17 EDT
See bugzilla bugs 196556, 196626, and 204260.  mkinitrd-5.0.32 needs to be
rebuilt against parted-1.7.1 and an errata issued along with the (hopefully)
upcoming parted errata.  This bug kept me on a 2.6.16 kernel with known security
problems for a VERY long time.
Comment 4 Fedora Update System 2006-08-30 17:36:04 EDT
mkinitrd-5.0.32-2 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Jason Smyth 2006-08-31 00:04:29 EDT
I had a similar problem, possibly even exactly the same, although the last
command visible on the screen when my system hung while booting was "Making
device-mapper control node." My suspicion is that the difference is related to
hardware configuration (I am booting to an LVM on a RAID array) but I can't say
for sure.

The fix in my case was to install a newer version of mkinitrd and then use that
to rebuild the kernel image in the boot directory.

I am using mkinitrd-5.1.8-1, but the earliest one I've heard of working is
5.1.2-1 (see comment 12 in Bug 196626). As of right now I see that the latest
version of mkinitrd available in the development repository is 5.1.9-1. I assume
this version will also work, but I can't say for sure since I haven't tested it.


Now that 5.0.32-2 has been pushed I will try testing that to see if it works
properly for me.
Comment 6 Peter Jones 2006-08-31 00:10:32 EDT
*** Bug 196626 has been marked as a duplicate of this bug. ***
Comment 7 Peter Jones 2006-08-31 00:14:04 EDT
*** Bug 196556 has been marked as a duplicate of this bug. ***
Comment 8 Jason Smyth 2006-09-01 00:54:18 EDT
Maybe this is a foolish question, but where can I find mkinitrd-5.0.32-2? I just
re-installed from scratch, and yum does not report any updates avaiable for
mkinitrd unless I enable to development repo. When checking the development
repo, I see the same version available that I saw previously, which was 5.1.9-1.

Right now I am still running 5.0.32-1, which I know does not work with the
2.6.17 kernels.
Comment 9 Jason Smyth 2006-09-01 04:40:46 EDT
Nevermind, I was able to find it by enabling the updates-testing repo. My
testing confirmed that this new build of mkinitrd should successfully resolve
the issues many users were experiencing with 2.6.17 kernels.
Comment 10 Marc Jadoul 2006-09-01 07:23:25 EDT
Not working for me!
I updated from testing to mkinitrd-5.0.32-2
run mkinitrd /boot/initrd-2.6.17-1.2174_FC5smp.img 2.6.17-1.2174_FC5smp

-> still same problem.

Did I missed something?

Note: 
1/ I also updated parted recently
2/ I did not installed mkinitrd 5.1.9 thus didn't upgraded glibc.
Comment 11 Fedora Update System 2006-09-01 09:05:54 EDT
mkinitrd-5.0.32-2 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 12 Jason Smyth 2006-09-01 13:31:35 EDT
Re: Comment 10

Have you tried using yum to remove and then reinstall the kernel package now
that you have mkinitrd-5.0.32-2 installed? I know some other people have
reported that that worked for them.

When I installed 5.0.32-2 from updates-testing, I did not need to update glibc
either. My testing was done on a freshly installed system and everything went
smoothly for me. The only things I had updated before updating mkinitrd and the
kernel were firefox and gaim, so I doubt that would have made any difference.
Comment 13 Markus Hakansson 2006-09-02 04:52:57 EDT
*** Bug 205009 has been marked as a duplicate of this bug. ***
Comment 14 Marc Jadoul 2006-09-03 17:24:08 EDT
I confirm:
I tried removing kernel and reinstalled with yum.
It still fail to boot!
I run on kernel-smp-2.6.17-1.2157_FC5. 

kernel-smp-2.6.17-1.2174_FC5 does NOT work for me. System seems to not find the
root partition.

I was followin this bug first: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=196556
Comment 15 Jason Smyth 2006-09-03 17:30:45 EDT
Marc, based on your comment in Bug 196556, I suspect you are experiencing a
different issue:

"kernel-smp-2.6.17-1.2174_FC5 does not boot while kernel-smp-2.6.17-1.2157_FC5
was OK!!"

To the best of my knowledge, this bug afflicted ALL kernel 2.6.17 releases, so
if 2.6.17-1.2157 works for you, but 2.6.17-1.2174 does not, I suspect the bug
you are experiencing is different from this one. You may want to consider
starting a new bug thread.
Comment 16 Till Maas 2008-01-08 21:54:06 EST
according to the comments the initially reported issue seems to be fixed. In
case there are still issues with custom kernel on Fedora 7 or 8, please open a
new bug report. Older releases of Fedora are no longer supported.

Note You need to log in before you can comment on or make changes to this bug.