Bug 189738 - No sound on Dell Precision 380 (82801G ICH7 Family)
No sound on Dell Precision 380 (82801G ICH7 Family)
Status: CLOSED DUPLICATE of bug 182940
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-24 03:08 EDT by Ville Ranki
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-11 16:27:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Ranki 2006-04-24 03:08:01 EDT
Description of problem:
No sound. Mixer settings should be correct. Sound works with
FC4 and Live distros.

Version-Release number of selected component (if applicable):
Linux version 2.6.16-1.2096_FC5 (bhcompile@hs20-bc1-3.build.redhat.com) 
(gcc version 4.1.0 20060304 (Red Hat 4.1.0-3)) #1 Wed Apr 19 05:14:36 EDT 2006

Additional info:

[root@localhost ~]# cat scsound.log
------- System Config Soundcard --------
Mon Apr 24 10:08:42 EEST 2006

------- lspci --------
00:00.0 Host bridge: Intel Corporation 955X Memory Controller Hub
00:01.0 PCI bridge: Intel Corporation 955X PCI Express Graphics Port
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express
Port 5 (rev 01)
00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express
Port 6 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface
Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GR/GH (ICH7 Family) Serial ATA
Storage Controllers cc=AHCI (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV41GL [Quadro FX 1400]
(rev a2)
04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit
Ethernet PCI Express (rev 01)
05:02.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 61)

------- lsmod --------
Module                  Size  Used by
nls_utf8                2241  1
vfat                   11969  1
fat                    47709  1 vfat
autofs4                19013  1
hidp                   15937  2
rfcomm                 34517  0
l2cap                  23617  10 hidp,rfcomm
bluetooth              44069  5 hidp,rfcomm,l2cap
sunrpc                136573  1
dm_mirror              19985  0
dm_mod                 50649  1 dm_mirror
video                  14917  0
button                  6609  0
battery                 9285  0
ac                      4933  0
ipv6                  225569  12
joydev                  9473  0
usb_storage            62497  1
lp                     12297  0
parport_pc             25445  1
parport                34313  2 lp,parport_pc
floppy                 57733  0
nvram                   8393  0
ohci1394               31749  0
snd_hda_intel          17233  1
snd_hda_codec         112065  1 snd_hda_intel
ieee1394              288665  1 ohci1394
snd_seq_dummy           3781  0
snd_seq_oss            28993  0
snd_seq_midi_event      7105  1 snd_seq_oss
snd_seq                47153  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
sg                     32349  0
snd_seq_device          8909  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            45009  0
snd_mixer_oss          16449  1 snd_pcm_oss
snd_pcm                76869  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
nvidia               4544884  12
tg3                    90309  0
i2c_i801                8397  0
snd_timer              22597  2 snd_seq,snd_pcm
snd                    50501  11
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9377  1 snd
hw_random               5849  0
i2c_core               20673  2 nvidia,i2c_i801
ehci_hcd               29005  0
uhci_hcd               28881  0
snd_page_alloc         10441  2 snd_hda_intel,snd_pcm
ext3                  116169  2
jbd                    52693  1 ext3
ahci                   12613  3
libata                 53969  1 ahci
sd_mod                 16449  6
scsi_mod              124648  5 usb_storage,sg,ahci,libata,sd_mod

------- /etc/modprobe.conf --------
alias scsi_hostadapter ahci
alias eth0 tg3
alias snd-card-0 snd-hda-intel
options snd-card-0 index=0
options snd-hda-intel index=0
remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-hda-intel
alias char-major-195* nvidia
options nvidia NVreg_ModifyDeviceFiles=0

------- /etc/asound.conf --------
#Generated by system-config-soundcard, do not edit by hand
#HWCONF
#DEV 0
pcm.!default { type hw card 0 device 0 }
ctl.!default { type hw card 0 }

------- aplay -l --------
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

------- amixer --------
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 24 [77%] [on]
  Front Right: Playback 24 [77%] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 194 [76%]
  Front Right: Playback 194 [76%]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [off]
  Front Right: Capture 0 [0%] [off]
Simple mixer control 'Capture Mux',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 4
  Front Left: 0 [0%]
  Front Right: 0 [0%]
Simple mixer control 'Input Source',0
  Capabilities: enum
  Items: 'Mic' 'Front Mic' 'Line'
  Item0: 'Mic'

------- /proc/asound/version --------
Advanced Linux Sound Architecture Driver Version 1.0.11rc2 (Wed Jan 04 08:57:20
2006 UTC).

------- rpm -q alsa-lib --------
alsa-lib-1.0.11-3.rc2.2

------- rpm -q alsa-utils --------
alsa-utils-1.0.11-4.rc2

------- /proc/asound/modules --------
 0 snd_hda_intel

------- /proc/asound/pcm --------
00-00: STAC92xx Analog : STAC92xx Analog : playback 1 : capture 2

------- system-config-soundcard --------

/usr/share/system-config-soundcard/soundcard.py:273: DeprecationWarning: use
gtk.ComboBox
  self.primarySubDeviceOptionMenu = gtk.OptionMenu()
/usr/share/system-config-soundcard/soundcard.py:308: GtkDeprecationWarning:
gtk.timeout_add is deprecated, use gobject.timeout_add instead
  self.timer = gtk.timeout_add (100, self.checkStatus, self)
/usr/share/system-config-soundcard/soundcard.py:548: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  gtk.main()
Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16
bit Little Endian, Rate 44100 Hz, Stereo
Read config:
card 0
device 0
HW 1
----------- Kudzu -------------
Desc:           Intel Corporation 82801G (ICH7 Family) High Definition Audio
Controller
Driver:         snd-hda-intel
Device:         None

----------- **** -------------
Comment 1 Matthias Saou 2006-04-27 07:40:53 EDT
Exact same problem here on the same hardware (Precision 380). On FC4 it worked
with OSS, but ALSA always gave me errors. With the latest FC4 updates and now
with FC5, no more errors with either OSS or ALSA, but no sound either... silence.

I've tried updating to alsa-lib and alsa-utils 1.0.11 final, but same problem.
Not sure if this is a kernel module problem or a userland library problem,
though, so please reassign to alsa-lib if required.
Comment 2 Brandon Petersen 2006-04-30 21:04:31 EDT
Same problem appears on a recently purchased Dell Inspiron 9400 Laptop.  It is
also using the Intel Corporation 82801G (ICH7 Family) High Definition Audio
hardware, and I get no sound.  My system details appear to be the same as
described above.
Comment 3 Joe Orton 2006-05-11 16:27:43 EDT

*** This bug has been marked as a duplicate of 182940 ***

Note You need to log in before you can comment on or make changes to this bug.