Bug 182940 - no sound output with Intel HDA/STAC92xx
no sound output with Intel HDA/STAC92xx
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
https://bugtrack.alsa-project.org/als...
:
: 187905 189738 190295 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 12:01 EST by Sammy
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 08:34:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file from sound card detection tool (6.39 KB, text/plain)
2006-03-21 21:36 EST, Demosthenes T. Mateo Jr.
no flags Details
alsa patch for 2.6.16 based FC5 kernel (584.86 KB, patch)
2006-04-12 09:37 EDT, Sammy
no flags Details | Diff

  None (edit)
Description Sammy 2006-02-24 12:01:54 EST
On a system where all packages are updated to rawhide 2/24/2006 (udev fixed
from cvs to udev-084-5). This is a x86_64 system.

Booting with kernel-2.6.15-1.1977_FC5 results in no sound, rebooting with
kernel-2.6.15-1.1826.2.14_FC5 (FC5test2 recompiled with 2.6.15.4 patch).
has perfectly functioning sound.

The hardware is hda_intel.

I have checked the loaded modules for both kernels, they are the same EXCEPT
in the column for how many modules are using snd_hda_intel I have 0 for the
new kernel an 3 for the old kernel, despite the fact that snd_hda_intel is
listed as being used. Any ideas?

The actual diff is:

31c31
< snd                   13
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
---
> snd                   9
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
33c33
< snd_hda_intel         3
---
> snd_hda_intel         0
36c36
< snd_pcm               4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
---
> snd_pcm               3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
43c43
< snd_timer             3 snd_seq,snd_pcm
---
> snd_timer             2 snd_seq,snd_pcm
Comment 1 Sammy 2006-02-24 14:52:19 EST
Some more experimentation:

modprobe -r snd_hda_intel
modprobe snd_hda_intel

Produces two messages:
kernel: azx_get_response timeout

Message from syslogd@compsci at Fri Feb 24 13:54:20 2006 ...
compsci kernel: general protection fault: 0000 [1] SMP
Comment 2 Sammy 2006-02-27 10:01:37 EST
Issue seen by other people as well. It is just been discussed on the
Linux-Kernel List.
http://www.tux.org/lkml/
Comment 3 Demosthenes T. Mateo Jr. 2006-03-21 21:36:13 EST
Created attachment 126450 [details]
log file from sound card detection tool

This is the output of the sound card detection tool. 

kernel 2.6.15-1.2054_FC5

I can see rhythmbox playing my ogg files but there is no sound coming out of
the speakers nor headphones.
Comment 4 Sammy 2006-03-22 10:15:58 EST
This is discussed in alsa bug #1843 as a regression for 2.6.16. After a long
process it is fixed in the latest alsa-kernel cvs. I just made a patch from
the cvs tree against 2.6.16 FC5 kernel and sound is working fine. This
changes the version to 1.0.11rc3 for alsa-kernel.

PS: The alsa bug talk about laptops but my problem was actually with a
    DELL desktop, so it works for all hda-intel problems. At least as
    far as hearing something!
Comment 5 Joe Orton 2006-04-05 09:33:55 EDT
Audio is silent here too; a new Dell Precision box, ICH7 chipset, STAC92xx
audio.  Added reference to the ALSA bug.
Comment 6 Joe Orton 2006-04-05 09:38:33 EDT
*** Bug 187905 has been marked as a duplicate of this bug. ***
Comment 7 Joe Orton 2006-04-05 09:40:10 EDT
Updating summary, note this is broken in 2.6.16-1.2080_FC5 still too.
Comment 8 Sammy 2006-04-12 09:37:14 EDT
Created attachment 127658 [details]
alsa patch for 2.6.16 based FC5 kernel
Comment 9 Sammy 2006-04-12 09:39:48 EDT
To fix this for FC5 stable you need to apply the alsa kernel patch from
3/22/2006 since this is 2.6.16 based. I am attaching what I have been
using on 2.6.16-1.2080_FC5 recompiled with 2.6.16.4. The 2.6.17 based
kernels would have this or a later version in already.
Comment 10 Joe Orton 2006-05-11 16:28:08 EDT
*** Bug 189738 has been marked as a duplicate of this bug. ***
Comment 11 Joe Orton 2006-05-11 16:30:53 EDT
*** Bug 190295 has been marked as a duplicate of this bug. ***
Comment 12 Alexei Podtelezhnikov 2006-05-22 14:24:50 EDT
FYI, it seems that FC4 with recently updated 2.6.16 kernels suffers from this 
bug as well. So I hope for official fix to be released for FC4 as well. 
Comment 13 Ville Ranki 2006-06-20 03:14:37 EDT
Anything new on this one? I think this should be quite
high priority for Redhat hackers as Dell officially supports
RHEL and current kernel/alsa still doen't work on new Dells.
Comment 14 Ville Ranki 2006-06-27 02:55:01 EDT
Works for me on kernel 2.6.17-1.2139_FC5smp
Comment 15 Sammy 2006-06-27 08:34:54 EDT
Ditto here since Alsa is updated to rc4 for 2.6.17. I am closing this bug.
Comment 16 Brian Millett 2006-06-27 09:54:35 EDT
Well, not so good for a dell D820.

I'm running 2.6.17-1.2139_FC5smp.

I get the following from dmegs:
--BEGIN--
snd_pcm: disagrees about version of symbol snd_timer_notify
snd_pcm: Unknown symbol snd_timer_notify
snd_pcm: disagrees about version of symbol snd_timer_interrupt
snd_pcm: Unknown symbol snd_timer_interrupt
snd_pcm: Unknown symbol snd_verbose_printk
snd_pcm: disagrees about version of symbol snd_timer_new
snd_pcm: Unknown symbol snd_timer_new
snd_hda_codec: Unknown symbol snd_pcm_hw_constraint_list
snd_hda_codec: Unknown symbol snd_pcm_hw_constraint_step
snd_hda_codec: Unknown symbol snd_pcm_format_width
snd_hda_intel: Unknown symbol snd_pcm_new
snd_hda_intel: Unknown symbol snd_pcm_limit_hw_rates
snd_hda_intel: Unknown symbol snd_pcm_lib_preallocate_pages_for_all
snd_hda_intel: Unknown symbol snd_hda_bus_new
snd_hda_intel: Unknown symbol snd_hda_build_pcms
snd_hda_intel: Unknown symbol snd_hda_codec_new
snd_hda_intel: Unknown symbol snd_hda_queue_unsol_event
snd_hda_intel: Unknown symbol snd_pcm_lib_malloc_pages
snd_hda_intel: Unknown symbol snd_pcm_lib_ioctl
snd_hda_intel: Unknown symbol snd_pcm_lib_free_pages
snd_hda_intel: Unknown symbol snd_hda_calc_stream_format
snd_hda_intel: Unknown symbol snd_pcm_set_ops
snd_hda_intel: Unknown symbol snd_hda_suspend
snd_hda_intel: Unknown symbol snd_pcm_suspend_all
snd_hda_intel: Unknown symbol snd_hda_resume
snd_hda_intel: Unknown symbol snd_pcm_hw_constraint_integer
snd_hda_intel: Unknown symbol snd_hda_build_controls
snd_hda_intel: Unknown symbol snd_pcm_period_elapsed
--END--

[bpm]$ sudo rpm -V kernel-smp-2.6.17-1.2139_FC5
[bpm]$

so the kernel is OK.

What I have in the modprobe.conf:
--BEGIN--
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
options snd-card-0 index=0 model=laptop-eapd
--END--

Note You need to log in before you can comment on or make changes to this bug.