Bug 18976 - gcc 2.96-55 breaks postfix
gcc 2.96-55 breaks postfix
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks: 18963
  Show dependency treegraph
 
Reported: 2000-10-12 12:31 EDT by Bernhard Rosenkraenzer
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-02 09:45:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Postfix SRPM that doesn't work with new glibc (943.99 KB, application/octet-stream)
2000-10-12 12:33 EDT, Bernhard Rosenkraenzer
no flags Details

  None (edit)
Description Bernhard Rosenkraenzer 2000-10-12 12:31:45 EDT
glibc 2.1.94-2 breaks the postfix build and the resulting binary (fails to
recognize comments in its configuration file).
glibc 2.1.92-14 (from 7.0) is ok.

I don't have the time to trace this down at the moment; attaching the
source RPM showing the problem for now.

The problem seems to be specific to x86.
Comment 1 Bernhard Rosenkraenzer 2000-10-12 12:33:25 EDT
Created attachment 4110 [details]
Postfix SRPM that doesn't work with new glibc
Comment 2 Jakub Jelinek 2000-10-13 05:31:06 EDT
Are you sure it worked against glibc-2.1.92-14?
The failing program AFAIC is bin/postconf, which if I run against
glibc 2.1.92-14 gives the same errors:
LD_TRACE_LOADED_OBJECTS=1 /usr/src/2.1.92-14/ld-linux.so.2 --library-path /usr/src/2.1.92-14/ bin/postconf -c /var/tmp/postfix-20000924-root/etc/postfix -e 'alias_maps = hash:/etc/postfix/aliases' 'alias_database = hash:/etc/postfix/aliases'
        libdb.so.2 => /usr/lib/libdb.so.2 (0x4000a000)
        libnsl.so.1 => /usr/src/2.1.92-14/libnsl.so.1 (0x40018000)
        libresolv.so.2 => /usr/src/2.1.92-14/libresolv.so.2 (0x4002f000)
        libc.so.6 => /usr/src/2.1.92-14/libc.so.6 (0x40041000)
        /lib/ld-linux.so.2 => /usr/src/2.1.92-14/ld-linux.so.2 (0x80000000)
ls -l /usr/src/2.1.92-14/libc.so.6 /usr/src/2.1.92-14/ld-linux.so.2
lrwxrwxrwx    1 root     root           12 Oct 13 11:25 /usr/src/2.1.92-14/ld-linux.so.2 -> ld-2.1.92.so
lrwxrwxrwx    1 root     root           14 Oct 13 11:25 /usr/src/2.1.92-14/libc.so.6 -> libc-2.1.92.so
/usr/src/2.1.92-14/ld-linux.so.2 --library-path /usr/src/2.1.92-14/ bin/postconf -c /var/tmp/postfix-20000924-root/etc/postfix -e 'alias_maps = hash:/etc/postfix/aliases' 'alias_database = hash:/etc/postfix/aliases'
bin/postconf: warning: /var/tmp/postfix-20000924-root/etc/postfix/main.cf: multiple entries for key alias_maps
bin/postconf: warning: /var/tmp/postfix-20000924-root/etc/postfix/main.cf: multiple entries for key alias_database
bin/postconf: fatal: read /var/tmp/postfix-20000924-root/etc/postfix/main.cf: Function not implemented

and if I just run postconf with the same arguments, I get the same result.
The Function not implemented is total crap, postfix does not know that it can
look at errno only if some function actually failed.
Comment 3 Bernhard Rosenkraenzer 2000-10-13 06:08:18 EDT
Yes. Like I've said, I didn't have the time to look into the problem at the
moment.
But I've tried compiling it on a couple of machines, and it consistently failed
on every x86 machine that has been updated, and worked on all non-x86 machines
and on all machines without updates.

Try: zell.redhat.de (doesn't work: updated), parma.redhat.de (works: not
updated), porky.devel.redhat.com (doesn't work: updated),
george.devel.redhat.com (works: alpha), bart.devel.redhat.com (works: sparc)

Maybe I messed up and attached the wrong source RPM, the error message I'm
getting is different (complains about format errors in comment lines because it
can't recognize them as such anymore).
Try the one on parma or zell, that's the one I was using.
Comment 4 Jakub Jelinek 2000-10-13 06:15:45 EDT
Actually it looks like gcc bug which was introduced in our gcc between
gcc-2.96-54 (the one that made it into the distribution) and gcc-2.96-55.
There were 15 patches added, I'll check them out.
I've first tried my i386_ge_geu but it looks like that was not it, I suspect
Jan Hubicka's patches. CVS head is broken as well.
Comment 5 Jakub Jelinek 2000-10-13 12:12:27 EDT
It is for sure 2.96-55, because downgrading to gcc 2.96-54 even with glibc
2.1.94-3 makes postfix build succeed. The broken patch is gcc-i386-arith.patch
from Jan Hubicka, to whom I spoke about it today in person, we decided on
how it should be fixed and he's probably just testing the fix out.
Comment 6 Jakub Jelinek 2000-11-02 09:45:50 EST
Fixed in gcc-2.96-62.

Note You need to log in before you can comment on or make changes to this bug.