Bug 189761 - Showing extra space with Lohit family of fonts
Summary: Showing extra space with Lohit family of fonts
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords: i18n
: 180124 (view as bug list)
Depends On:
Blocks: Indic
TreeView+ depends on / blocked
 
Reported: 2006-04-24 13:59 UTC by Satyabrata Maitra
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: OpenOffice.org-2.0.2-5.12.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-28 04:50:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 64743 None None None Never

Description Satyabrata Maitra 2006-04-24 13:59:51 UTC
Description of problem:
In oowriter, in case of any english word or entry, pressing space bar is
resulting some extra space after the word entered.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.2-5.9.3
openoffice.org-langpack-bn-2.0.2-5.9.3

How reproducible:
Always

Steps to Reproduce:
1.Open oowriter
2.Try to write any word or character in english or copy any paragraph combined 
  with both english and other language words.
3.Hit the space bar. 
4.Observe the result.
  
Actual results:
Hitting space bar is resulting the cursor to be positioned with an extra space
ahead than it should be positioned.

Expected results:
Hitting the space bar should positioned the cursor excatly a space ahead (not
like a tab space).

Additional info:

Comment 1 Caolan McNamara 2006-04-24 14:01:02 UTC
Can you attach a sample document that you created like above and attach it to
this issue ?

Comment 2 Caolan McNamara 2006-04-24 17:08:43 UTC
Interesting, I can reproduce this one. It appears to be the Lohit family of
fonts, not the actual language that causes this. With Lohit Bengali being the
default font when in bn_IN/bn_BD locale

Comment 3 Caolan McNamara 2006-04-25 12:07:50 UTC
Excellent, it's the same underlying problem as
http://www.openoffice.org/issues/show_bug.cgi?id=64743. Bad placement of glyphs
during substitution. So the same patch will work for this.

Comment 4 Caolan McNamara 2006-04-26 09:25:36 UTC
*** Bug 180124 has been marked as a duplicate of this bug. ***

Comment 5 Satyabrata Maitra 2006-04-27 13:53:53 UTC
Excellent! In OpenOffice.org-2.0.2-5.12.3 version, the patch worked. Extra space
are not appearing. Thanks for ur great effort. 


Note You need to log in before you can comment on or make changes to this bug.