Bug 18977 - Kickstart not working with image over NFS
Kickstart not working with image over NFS
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On: 17609
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 12:40 EDT by Marc Schmitt
Modified: 2007-03-26 23:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 16:15:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc Schmitt 2000-10-12 12:40:56 EDT
Hello

I`ve been using KS installations with RH 6.0 and 6.2 and it works well.
Trying to do a kickstart installation with RH 7.0 fails. I want to install
over the network via NFS, the ks.cfg file residing on the boot floppy
(bootnet.img).

I`m using basicly the same ks.cfg file as with RH 6.2 except that I added
the --hostname line to the network option.

Instead of doing the unattended install, the installer gets interactive,
asking for language and stuff.

On Alt-F3 the last line says "mounting nfs path hostxxx:/diryyy", but
actually the request never arrives on the server, as indicates
/var/log/messages.

Following the interactive installer and entering manually the nfs server
and the mount dir after providing IP information will result in a succesful
mounting and anaconda starts to load. The lines read:
Running anaconda - may take some time to load...
exec: No such file or directory
install exited abnormally
sending termination signals...done
etc etc
you may safely reboot your system



In addition, I noticed that I can`t mount the image from a Sun NFS server,
which worked well with RH 6.0 and 6.2. I had to install an NFS Server under
Linux to get it working at all.
Trying to mount the image directory from the Sun simply returns an error
dialog: "I could not mount that directory from the server."


Regards,
Marc
Comment 1 Dax Kelson 2000-10-12 15:00:13 EDT
I've done 200 kickstart installs over NFS with Red Hat 7.0.

You probably didn't copy the 2nd cdrom to your hard drive properly.  Use the
commands, in the RELEASE-NOTES on cdrom1 to copy the files.  I bet you are
missing your "instimage" directory.

Also, you should read over the new kickstart appendix in the official reference
guide, I bet you have some additional changes to make to your ks.cfg file.

Good luck,

Dax Kelson
Guru Labs

Comment 2 Marc Schmitt 2000-10-13 05:34:59 EDT
Hi Dax

Thanks for your hints! I copied the 2 CDs like adviced in the RELEASE-NOTES and
the problem "exec: No such file or directory" disapeared. I initially made a 1
to 1 copy of ftp://sunsite.cnlab-switch.ch/mirror/redhat/redhat-7.0/i386/en/,
which should have the same content, but obviously not...

The problem with the Sun server remains. We are using SunOS 5.6 on an Ultra-4.
Did you export the image directory from a linux box or a Sun?

Greetz
Marc
Comment 3 tek 2000-10-13 10:31:54 EDT
Marc, see Bug #17609.  I've made some images available to allow you to mount 
the Sun server....

-Thom
Comment 4 Brock Organ 2000-10-18 16:15:02 EDT
hi Marc,

glad to hear that Dax's notes helped ... ! Since they solved your immeadiate
problem (the copy of CDs #1 & #2), I'll close this bug report ... feel free to
follow the related NFS issues in 17609 ... thanks for your report!



Note You need to log in before you can comment on or make changes to this bug.