Bug 189847 - Firefox Crashes if Flash is installed
Firefox Crashes if Flash is installed
Status: CLOSED DUPLICATE of bug 155582
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-24 22:09 EDT by Stephen Kilbourn
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-17 14:32:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Kilbourn 2006-04-24 22:09:43 EDT
Description of problem:
Firefox completely freezes when I access any pages with Flash. This only happens
when I have Flash installed; it works as soon as I unisntall Flash.  Everything
worked fine with Firefox 1.5.0.1

Version-Release number of selected component (if applicable):
Firefox 1.5.0.2
Macromedia Flash Player 7 for Linux

How reproducible:
Any site visited that contains flash, e.g.
http://www.macromedia.com/shockwave/welcome/

Steps to Reproduce:
1. Install Flash 7 with yum while running Firefox 1.5.0.1
   (also if I uninstall, then reinstall after the upgrade)
2. Let PUP upgrade Firefox 1.5.0.1 to 1.5.0.2
3. Visit a site with flash
  
Actual results:
Firefox crashes. I have to force quit

Expected results:


Additional info:
Comment 1 Steve 2006-05-04 17:28:38 EDT
Same problem here, but only with fedora rawhide (fc6). If i visit a site with
flash, firefox quits.
Comment 2 Claudio Tibaldi 2006-05-28 10:26:39 EDT
Same problem, but FC5 with firefox 1.5.0.3.
Comment 3 Steve 2006-06-03 08:44:47 EDT
Here is a workaround:

Create a file in /etc/profile.d called flash.sh. Include this in it:

export XLIB_SKIP_ARGB_VISUALS=1

--

This works for Me in fedora rawhide (fc6).
Comment 4 Warren Togami 2006-06-03 11:25:56 EDT
In response to Comment #3:
That workaround is only true if you enabled COMPOSITE in order to use AIGLX. 
Bug #155582

There is indeed some kind of crash related to browser plugins affecting firefox,
but it seems difficult to pin down...
Comment 5 Jan-Thomas Czornack 2006-06-17 13:16:37 EDT
(In reply to comment #3)
> Here is a workaround:
> 
> Create a file in /etc/profile.d called flash.sh. Include this in it:
> 
> export XLIB_SKIP_ARGB_VISUALS=1
> 
> --
> 
> This works for Me in fedora rawhide (fc6).

Just setting that variable before starting firefox seems to be enough. I worked
on my FC5 with firefox 1.5.0.4. Since I have not noticed any changes/updates to
xorg or its configuration (in yum.log), it seems to be a firefox problem.
Comment 6 Warren Togami 2006-06-17 14:32:12 EDT

*** This bug has been marked as a duplicate of 155582 ***

Note You need to log in before you can comment on or make changes to this bug.