Bug 189860 - oocalc crashes when reading or writing Excel xml files
oocalc crashes when reading or writing Excel xml files
Status: CLOSED DUPLICATE of bug 182263
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-25 07:05 EDT by Peter Gordon
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 08:23:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A small example Excel file (3.55 KB, text/plain)
2006-04-25 07:05 EDT, Peter Gordon
no flags Details

  None (edit)
Description Peter Gordon 2006-04-25 07:05:00 EDT
Description of problem:


Version-Release number of selected component (if applicable):
2.0.2

How reproducible:
Reading a simple Excel xml causes a crash.
Writing any Excel xml file, even an empty one, causes a crash

Steps to Reproduce:
1. oocalc 
2. File/Save As../ File Type Microsoft Excel 2003 XML (.xml)
3. Crashes

Alterate:
1. oocalc 
2. File/Open (attached file)
3. Crashes
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Gordon 2006-04-25 07:05:00 EDT
Created attachment 128193 [details]
A small example Excel file
Comment 2 Caolan McNamara 2006-04-25 08:23:07 EDT
Opening that document doesn't crash for me :-(

When office crashed, it should have shown a crash reporter window with some
debugging information in it. Did it do that ? If so can you cut and paste that
debugging information into this bug.

I believe that this is most likely to be a duplicate of the problem of bug
182263 which *should* be fixed by updates to libgcj

*** This bug has been marked as a duplicate of 182263 ***
Comment 3 Peter Gordon 2006-04-25 08:58:58 EDT
This is the crash report

Collecting from unknown thread.

---start copy and paste here---
Video Driver is probably: radeon
Desktop is: not GNOME
libgcj version is: libgcj-4.1.0-3
kernel is: Linux 2.6.16-1.2080_FC5 #1 Tue Mar 28 03:38:34 EST 2006 i686 i686 i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.7.2
accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x45e8680: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e680
0x45e8ec0: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1eec0
0x83e420:  + 0x420 (__kernel_sigreturn + 0x0)
0x8896e3: /lib/libc.so.6 + 0x296e3 (abort + 0x103)
0xb533fec8: /usr/lib/libgcj.so.7 + 0x100fec8
0xb5346215: /usr/lib/libgcj.so.7 + 0x1016215 (GC_push_all_stacks + 0x105)
0xb5341957: /usr/lib/libgcj.so.7 + 0x1011957 (GC_default_push_other_roots + 0x17)
0xb533f3ec: /usr/lib/libgcj.so.7 + 0x100f3ec (GC_push_roots + 0xbc)
0xb533ec47: /usr/lib/libgcj.so.7 + 0x100ec47 (GC_mark_some + 0x1b7)
0xb53368db: /usr/lib/libgcj.so.7 + 0x10068db (GC_stopped_mark + 0x9b)
0xb5336c8c: /usr/lib/libgcj.so.7 + 0x1006c8c (GC_try_to_collect_inner + 0x9c)
0xb5336f98: /usr/lib/libgcj.so.7 + 0x1006f98 (GC_collect_or_expand + 0x148)
0xb533bc40: /usr/lib/libgcj.so.7 + 0x100bc40 (GC_alloc_large + 0xa0)
0xb533c01b: /usr/lib/libgcj.so.7 + 0x100c01b (GC_generic_malloc + 0xdb)
0xb533c405: /usr/lib/libgcj.so.7 + 0x100c405 (GC_malloc_atomic + 0xa5)
0xb4d108a5: /usr/lib/libgcj.so.7 + 0x9e08a5 (_Jv_NewPrimArray + 0x55)
---end copy and paste here---
paste the above into your bug report
Comment 4 Peter Gordon 2006-04-25 09:04:41 EDT
Then the question remains, how do I get an update to libgcj?
Comment 5 Caolan McNamara 2006-04-25 11:27:28 EDT
My apologies, the update hasn't been released yet. When it it, 
yum -y update libgcj
will do the right thing.

Note You need to log in before you can comment on or make changes to this bug.