Bug 182263 - SIGABRT : libgcj GC_malloc_atomic(?) on export to xhtml from OOo writer
SIGABRT : libgcj GC_malloc_atomic(?) on export to xhtml from OOo writer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 183892 187866 187928 188190 189860 191705 193879 (view as bug list)
Depends On: 180637
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 10:15 EST by Caolan McNamara
Modified: 2007-11-30 17:11 EST (History)
11 users (show)

See Also:
Fixed In Version: 4.1.0-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 02:30:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stacktrace of gdb /usr/lib/openoffice.org2.0/program/soffice.bin (10.64 KB, text/plain)
2006-02-21 10:15 EST, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 13212 None None None Never

  None (edit)
Description Caolan McNamara 2006-02-21 10:15:23 EST
Description of problem:

stacktrace from gdb attached


Version-Release number of selected component (if applicable):
gcc-4.1.0-0.29
kernel-2.6.15-1.1969_FC5
openoffice.org-xsltfilter-2.0.1.1-11.2.2
xerces-j2-2.6.2-6jpp_5fc

How reproducible:
everytime


Steps to Reproduce:
1. install openoffice.org-xsltfilter
2. start writer
3. "export" to xhtml
  
Actual results:
*boom*

Expected results:


Additional info:
/usr/sbin/sestatus
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 20
Policy from config file:        targeted
Comment 1 Caolan McNamara 2006-02-21 10:15:23 EST
Created attachment 124956 [details]
stacktrace of gdb /usr/lib/openoffice.org2.0/program/soffice.bin
Comment 2 Caolan McNamara 2006-02-22 03:55:22 EST
I wonder if this is the same as bug 180637
Comment 3 Jakub Jelinek 2006-02-22 04:30:18 EST
Does soffice.bin link against libgcj.so or it dlopens it?
#180637 is supposed to be fixed, libgcj.so now exports pthread_create
that should override pthread_create from libpthread.so.
Comment 4 Caolan McNamara 2006-02-22 04:31:46 EST
It dlopens it.
Comment 5 Bryce McKinlay 2006-02-23 11:45:35 EST
I don't think this is the same as 180637, but its related. From looking at the
stack trace, it appears this thread was never registered with the GC. This was a
known problem previously, and it should have been fixed by this patch:

2006-02-06  Jakub Jelinek  <jakub@redhat.com>
            Anthony Green  <green@redhat.com>
            Tom Tromey  <tromey@redhat.com>

        * include/gc_ext_config.h.in: Added GC_PTHREAD_SYM_VERSION.
        * include/gc_config.h.in: Rebuilt.
        * include/gc_pthread_redirects.h (pthread_create): Conditionally
        define.
        * pthread_support.c (pthread_create_): New global.
        (constr): New function.
        (pthread_create): Conditionally renamed.
        * configure: Rebuilt.
        * configure.ac (GC_PTHREAD_SYM_VERSION): Define.

So, either you don't have this patch or its not working for OO.org for some reason.

bug 180637, on the other hand, was _caused_ by this patch - it occurs when a
native, non-Java thread changes the signal mask to block the GC's suspend signal
- so you'll get a hang, not a SIGABRT.

Either way, the fix for bug 180637 that I'm working on should fix this as well.
Comment 6 Caolan McNamara 2006-03-04 09:07:36 EST
*** Bug 183892 has been marked as a duplicate of this bug. ***
Comment 7 Caolan McNamara 2006-03-16 06:56:02 EST
The java code in question uses
t = new Thread(){...

t.start()

from java code run in a jvm from a dlopened libgcj. I guess this isn't going to
get fixed for FC5 ?
Comment 8 David Woodhouse 2006-03-16 07:05:02 EST
If this is still happening in FC5 then bug #183892 probably wasn't a duplicate,
because it's gone away. On a clean FC5 installation yesterday, the letter wizard
worked fine.
Comment 9 Bryce McKinlay 2006-03-16 08:58:51 EST
I have a patch that I think should fix this, but I have yet to build it in to
the FC5 libgcj and test OO.org. I'm working on this today and I'll let you know
how it  goes.
Comment 10 Bryce McKinlay 2006-03-30 02:03:02 EST
gcc41-java-gc-thread-attach-2.patch, in the GCC bugzilla, should fix this:

http://gcc.gnu.org/PR13212
Comment 11 Caolan McNamara 2006-04-04 03:38:34 EDT
*** Bug 187866 has been marked as a duplicate of this bug. ***
Comment 12 Caolan McNamara 2006-04-05 03:36:45 EDT
*** Bug 187928 has been marked as a duplicate of this bug. ***
Comment 13 Ignacio Vazquez-Abrams 2006-04-06 15:44:47 EDT
*** Bug 188190 has been marked as a duplicate of this bug. ***
Comment 14 Jakub Jelinek 2006-04-07 02:30:59 EDT
Should be fixed in gcc-4.1.0-6 in rawhide (thanks Bryce).
Let's test it now on all arches.
Comment 15 Caolan McNamara 2006-04-07 04:52:00 EDT
most excellent
Comment 16 Caolan McNamara 2006-04-25 08:23:11 EDT
*** Bug 189860 has been marked as a duplicate of this bug. ***
Comment 17 Caolan McNamara 2006-04-25 10:41:41 EDT
was this not pushed as a FC5 update yet ?
Comment 18 Jakub Jelinek 2006-04-25 10:47:54 EDT
No, the amount of gcc bugreports is still quite high and thus more bugs should
accumulate before FC5 updates.  A timeframe is about a fortnight till month
from now.
Comment 19 Caolan McNamara 2006-05-15 07:38:16 EDT
*** Bug 191705 has been marked as a duplicate of this bug. ***
Comment 20 Caolan McNamara 2006-06-02 11:51:32 EDT
*** Bug 193879 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.