Bug 189932 - xenU kernels should not be installed to /boot/grub/menu.lst
xenU kernels should not be installed to /boot/grub/menu.lst
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Brian Brock
:
: 184213 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-25 17:16 EDT by Mike
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 12:57:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike 2006-04-25 17:16:20 EDT
Description of problem:

It appears that a generic kernel installation routine is being used to install
xenU kernels and that causes them to be added to /boot/grub/menu.lst for
boot-time selection.

Version-Release number of selected component (if applicable):

FC5

How reproducible:

Repeatable

Steps to Reproduce:
1. install a xenU kernel
2. check /boot/grub/menu.lst for entry for newly installed kernel
Comment 1 Jeremy Katz 2006-04-26 12:57:54 EDT
This is intentional as you need to have them installed that way in the guest.
Comment 2 Mike 2006-04-26 13:49:25 EDT
Is there documentation for how this is supposed to be used?

Either way, it is misleading when you boot the host and see a kernel in the list
that cannot be booted on physical hardware.
Comment 3 Jeremy Katz 2006-04-26 16:08:42 EDT
*** Bug 184213 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.