Bug 189935 - Missing BuildRequires in spec file.
Summary: Missing BuildRequires in spec file.
Status: CLOSED DUPLICATE of bug 191760
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Monty
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-25 21:26 UTC by Rob Andrews
Modified: 2013-10-20 22:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-15 00:55:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rob Andrews 2006-04-25 21:26:26 UTC
Description of problem:
rhythmbox is missing some BuildRequires in the spec file. I was investigating
why audioscrobbler support hadn't been built in (it defaults to enabled in
configure unless its dependancies aren't installed), but came across a few
problems when building.

Firstly, it is missing a BuildRequires on gstreamer-devel. When it came to
building, and I found I hadn't installed gstreamer-devel, the build failed. As
you well know, rpmbuild usually grunts if you are missing a BuildRequire :)

Secondly, it is missing a build dependancy on libtool. The build fails quite
late in because of this.

Thirdly, the executable links against libsoup but the build fails unless
libsoup-devel is installed. As a result, I suspect this may be a BuildRequire also. 

Version-Release number of selected component (if applicable):
rhythmbox-0.9.4-2

How reproducible:
Always.

Steps to Reproduce:
1. rpm -e gstreamer-devel libtool libsoup-devel
2. rpmbuild --rebuild rhythmbox-0.9.4-2.src.rpm
3. See it fail until you install at least gstreamer-devel, libtool and
libsoup-devel.

I am sorry for such a pedantic bug report!

Comment 1 Rob Andrews 2006-04-25 21:27:30 UTC
Ooops, audioscrobbler support *had* been built in, the location had changed
since rhythmbox 0.9.3, but the BuildRequires are still outstanding.

Comment 2 Bill Nottingham 2006-06-15 00:55:56 UTC

*** This bug has been marked as a duplicate of 191760 ***


Note You need to log in before you can comment on or make changes to this bug.