Bug 189963 - [PATCH] x86_64: race in the free_iommu fast path leaks entries.
Summary: [PATCH] x86_64: race in the free_iommu fast path leaks entries.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: x86_64
OS: Linux
medium
urgent
Target Milestone: ---
: ---
Assignee: Brian Maly
QA Contact: Brian Brock
URL: http://www.x86-64.org/lists/discuss/m...
Whiteboard:
Keywords:
: 191552 (view as bug list)
Depends On:
Blocks: 198694
TreeView+ depends on / blocked
 
Reported: 2006-04-26 08:41 UTC by Neil Turton
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 01:11:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0304 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 5 2007-04-28 18:58:50 UTC

Description Neil Turton 2006-04-26 08:41:36 UTC
Description of problem:
After a period of heavy I/O using a 32-bit bus mastering PCI network card on a
machine with 6G of RAM, the IOMMU runs out of space which can then cause 32-bit
PCI devices to fail.  This is caused by a race condition in free_iommu causing
bits to be set in the allocation bitmap which should not be.  After this has
happened many times, the IOMMU becomes full and devices trying to use it stop
working.

Version-Release number of selected component (if applicable):

All 2.6 kernels before 2.6.17-rc2.

How reproducible:


Steps to Reproduce:
1.Use a x86_64 SMP machine with 6G or more of RAM and an IOMMU.
2.Use a 32-bit bus mastering device.
3.Perform lots of concurrent I/O with the device until the IOMMU fills up.
  
Actual results:
The message "PCI-DMA: Out of IOMMU space for 53248 bytes at device
0000:03:05.0"

Expected results:


Additional info:
The patch on the mailing list fixes this problem.

As a PCI card manufacturer, we have customers waiting for this patch so your
assistance would be appreciated.

Comment 1 Neil Turton 2006-04-26 13:30:58 UTC
I should have said that we'd like this fixed for both RHEL and Fedora.  Many
thanks for your help

Comment 2 Jason Baron 2006-04-27 16:27:14 UTC
ok, can you please point us at the patch? thanks.

Comment 3 Neil Turton 2006-04-28 08:00:33 UTC
Sorry.  A slight brain failure.  I put it in the URL box.  Here it is again.

http://www.x86-64.org/lists/discuss/msg08781.html

Comment 4 Jim Paradis 2006-05-24 23:53:26 UTC
*** Bug 191552 has been marked as a duplicate of this bug. ***

Comment 5 Jim Paradis 2006-05-30 22:13:42 UTC
Patch posted to rhkernel-list

Comment 9 Jason Baron 2006-08-29 18:23:41 UTC
committed in stream U5 build 42.3. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 11 RHEL Product and Program Management 2006-10-12 22:47:54 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 12 Jay Turner 2006-10-17 15:39:24 UTC
QE ack for RHEL4.5.

Comment 14 Red Hat Bugzilla 2007-03-18 22:38:52 UTC
User jparadis@redhat.com's account has been closed

Comment 16 Red Hat Bugzilla 2007-05-08 01:11:03 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html


Note You need to log in before you can comment on or make changes to this bug.