Bug 189997 - Nasty PTR record from ssh and segfault in glibc
Summary: Nasty PTR record from ssh and segfault in glibc
Status: CLOSED DUPLICATE of bug 190002
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-26 15:27 UTC by Jon Masters
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-27 09:53:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testcase (587 bytes, text/plain)
2006-04-27 09:44 UTC, Tomas Mraz
no flags Details

Description Jon Masters 2006-04-26 15:27:41 UTC
Description of problem:

Openssh refuses incoming connections and returns errors in the logs:

Nasty PTR record "perihelion.int.jonmasters.org" is set up for 192.168.1.3, ignoring

Version-Release number of selected component (if applicable):

4.3p2

How reproducible:

Very.

Steps to Reproduce:
1. ssh into box
2. it fails
3.
  
Actual results:

Cannot connect via ssh

Expected results:

Can connect to box

Additional info:

Tomas says it might be a problem glibc with a change in sematics to getaddrinfo.

Comment 1 Jon Masters 2006-04-26 15:40:37 UTC
Setting "UseDNS no" in sshd_config works around the problem temporarily.

Comment 2 Tomas Mraz 2006-04-27 09:44:14 UTC
Created attachment 128294 [details]
Testcase

Here is the testcase.

Comment 3 Tomas Mraz 2006-04-27 09:48:17 UTC
So this is definitely a bug in glibc. At least it shouldn't segfault and I think
the semantics shouldn't change either.


Comment 4 Jakub Jelinek 2006-04-27 09:53:32 UTC

*** This bug has been marked as a duplicate of 190002 ***


Note You need to log in before you can comment on or make changes to this bug.