Bug 189998 - yum installs both x86_64 and noarch versions of a package
yum installs both x86_64 and noarch versions of a package
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 192837 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-26 11:28 EDT by Jerry James
Modified: 2014-01-21 17:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 10:31:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2006-04-26 11:28:43 EDT
Description of problem:
When a package has been released with both x86_64 and noarch versions, yum tries
to install them both.  I first noticed this when "yum install sabayon-admin"
failed.  It had tried to install both sabayon-admin-2.12.3-3.x86_64.rpm and the
older sabayon-admin-0.18-1.noarch.rpm.  A look through my installed packages
shows that this has happened before without me noticing it: I had both 
xmms-skins-1.2.10-13.x86_64.rpm and xmms-skins-1.2.10-15.noarch.rpm installed,
for example.  My i386 using friends tell me that this doesn't happen to them, so
it appears to be specific to the x86_64 version of yum.

Version-Release number of selected component (if applicable):
yum-2.6.0-1

How reproducible:
Always

Steps to Reproduce:
1. On an x86_64 machine, invoke "yum install sabayon-admin"
2.
3.
  
Actual results:
Yum tries to install both the current version and an older, noarch, version of
sabayon-admin.  The latter fails due to missing dependencies.

Expected results:
Yum should install only the current version.

Additional info:
Comment 1 Jeremy Katz 2006-04-26 13:35:56 EDT
Ugh.  This is caused by the fact that there are older versions of the packages
still in the tree.  

Sending a proposed patch to yum-devel and we'll go from there.  Simple
workaround is to do 'yum install sabayon-admin.x86_64'
Comment 2 Seth Vidal 2006-05-24 01:36:41 EDT
*** Bug 192837 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2006-05-24 10:31:32 EDT
And committed to upstream CVS, will be in 2.6.2 and 2.7.0

Note You need to log in before you can comment on or make changes to this bug.