Bug 192837 - yum ignores newer noarch packages when arch-specific package exists
yum ignores newer noarch packages when arch-specific package exists
Status: CLOSED DUPLICATE of bug 189998
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 11:07 EDT by Shahms E. King
Modified: 2014-01-21 17:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 01:36:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shahms E. King 2006-05-23 11:07:54 EDT
Description of problem:
When doing a yum install or yum update newer noarch packages are ignored if an
arch-specific package exists in the repository. I'm filing against yum because
that's where I see the behavior, but it may be an rpm problem.

Version-Release number of selected component (if applicable):
yum-2.6.1-0.fc5 (though it happened in FC4 as well)

How reproducible:
Always

Steps to Reproduce:
1. yum install python-reportlab
2. Watch as yum tries to install the FC3-era python-reportlab-1.19-1.i386
3.
  
Actual results:
yum attempts to install the older, but arch-specific package which fails as it
is an FC3 package which requires python 2.3.

Expected results:
yum installs the newer noarch pacakge

Additional info:
I think there may be a related bug in the scripts which manage the repository as
the offending package(s) shouldn't be in the FC4/FC5 repository at all as they
are un-rebuilt FC3 packages.
Comment 1 Seth Vidal 2006-05-24 01:15:01 EDT
ah ha. This is the part I didn't understand from the email thread. You're not
talking about for updates, you're talking about for a new install. In the case
of an update yum will dtrt when it comes to upgrading from i386->noarch and
vice-versa. But the install appears to be looking for the best arch first then
version of that one.

I'll look into this one, thanks.
Comment 2 Seth Vidal 2006-05-24 01:36:18 EDT

*** This bug has been marked as a duplicate of 189998 ***
Comment 3 Seth Vidal 2006-05-24 01:38:00 EDT
Jeremy, could you go ahead and merge the patch - I'm pretty sure it solves the
problem for both these bugs.

thanks

Note You need to log in before you can comment on or make changes to this bug.