Bug 190115 - g++ crashes when building a program
g++ crashes when building a program
Status: CLOSED DUPLICATE of bug 188125
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-27 13:59 EDT by pmarques
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-27 14:43:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source stored into /tmp/ccCNSrYR.out (1.17 MB, text/plain)
2006-04-27 13:59 EDT, pmarques
no flags Details

  None (edit)
Description pmarques 2006-04-27 13:59:13 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.try to build 3ddesktop-0.2.9-1.src.rpm

Actual results:

rpmbuild -ba 3ddesktop.spec
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.24199
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /usr/src/redhat/BUILD
+ rm -rf 3ddesktop-0.2.9
+ /bin/gzip -dc /usr/src/redhat/SOURCES/3ddesktop-0.2.9.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd 3ddesktop-0.2.9
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.91237
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd 3ddesktop-0.2.9
+ LANG=C
+ export LANG
+ unset DISPLAY
+ CFLAGS=
+ ./configure --prefix=/usr --sysconfdir=/etc --datadir=/usr/share
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for X... libraries , headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for dirent.h that defines DIR... yes
checking for library containing opendir... none required
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for unistd.h... (cached) yes
checking for gethostbyname... (cached) yes
checking for connect... (cached) yes
checking for remove... (cached) yes
checking for shmat... (cached) yes
checking for IceConnectionNumber in -lICE... (cached) yes
checking GL/gl.h usability... yes
checking GL/gl.h presence... yes
checking for GL/gl.h... yes
checking for XextCreateExtension in -lXext... yes
checking for XF86VidModeSetViewPort in -lXxf86vm... yes
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking build system type... powerpc-unknown-linux-gnu
checking host system type... powerpc-unknown-linux-gnu
checking for main in -lm... yes
checking for OpenGL... yes
checking for cos in -lm... yes
checking for imlib2-config... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking for gettimeofday... yes
checking for mkdir... yes
checking for strerror... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating 3ddesktop.spec
config.status: creating maketar.sh
config.status: creating config.h
config.status: executing depfiles commands
+ make
cd . && /bin/sh /usr/src/redhat/BUILD/3ddesktop-0.2.9/missing --run autoheader
rm -f stamp-h1
touch config.h.in
cd . && /bin/sh ./config.status config.h
config.status: creating config.h
config.status: config.h is unchanged
make  all-am
make[1]: Entering directory `/usr/src/redhat/BUILD/3ddesktop-0.2.9'
if g++ -DHAVE_CONFIG_H -I. -I. -I.    -Wall -O3 -DQT_CLEAN_NAMESPACE
-DSHAREDIR=\"/usr/share/3ddesktop\" -DSYSCONFDIR=\"/etc\"   -g -O2  -MT 3ddesk.o
-MD -MP -MF ".deps/3ddesk.Tpo" -c -o 3ddesk.o 3ddesk.cpp; \
then mv -f ".deps/3ddesk.Tpo" ".deps/3ddesk.Po"; else rm -f ".deps/3ddesk.Tpo";
exit 1; fi
g++ -Wall -O3 -DQT_CLEAN_NAMESPACE -DSHAREDIR=\"/usr/share/3ddesktop\"
-DSYSCONFDIR=\"/etc\"   -g -O2    -o 3ddesk  3ddesk.o  -lm -lXxf86vm -lXext  
-lSM -lICE -lSM -lICE
if g++ -DHAVE_CONFIG_H -I. -I. -I.    -Wall -O3 -DQT_CLEAN_NAMESPACE
-DSHAREDIR=\"/usr/share/3ddesktop\" -DSYSCONFDIR=\"/etc\"   -g -O2  -MT
3ddeskd.o -MD -MP -MF ".deps/3ddeskd.Tpo" -c -o 3ddeskd.o 3ddeskd.cpp; \
then mv -f ".deps/3ddeskd.Tpo" ".deps/3ddeskd.Po"; else rm -f
".deps/3ddeskd.Tpo"; exit 1; fi
3ddeskd.cpp: In function 'void draw_digit(int, float, float)':
3ddeskd.cpp:634: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccCNSrYR.out file, please attach this to
your bugreport.
make[1]: *** [3ddeskd.o] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/3ddesktop-0.2.9'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.91237 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.91237 (%build)
[root@minime SPECS]# g++ --version
g++ (GCC) 4.1.0 20060304 (Red Hat 4.1.0-3)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Expected results:


Additional info:
Comment 1 pmarques 2006-04-27 13:59:13 EDT
Created attachment 128316 [details]
Preprocessed source stored into /tmp/ccCNSrYR.out
Comment 2 Jakub Jelinek 2006-04-27 14:43:03 EDT

*** This bug has been marked as a duplicate of 188125 ***

Note You need to log in before you can comment on or make changes to this bug.