Bug 188125 - 3ddesktop crashes gcc
3ddesktop crashes gcc
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 190115 190369 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 05:19 EDT by Naresh
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-06 07:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
3ddesktop crashing the gcc4 in fedora core 5 (1.17 MB, text/plain)
2006-04-06 05:19 EDT, Naresh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 27056 None None None Never

  None (edit)
Description Naresh 2006-04-06 05:19:51 EDT
Description of problem:
when trying to build 3ddesktop on fedora core 5 gcc will exit with error message

Version-Release number of selected component (if applicable):
3ddesktop-0.2.9
gcc version 4.1.0 20060304 (Red Hat 4.1.0-3)
How reproducible:
easily reproducibile in any fedora core 5 system.

Steps to Reproduce:
1. download the 3ddesktop srpm from sf.net
2. rpmbuild --rebuild 3ddesktop-0.2.9-1.src.rpm
3. <this will exit with error messages>
  
Actual results:
make[1]: Entering directory `/usr/src/redhat/BUILD/3ddesktop-0.2.9'
if g++ -DHAVE_CONFIG_H -I. -I. -I.    -Wall -O3 -DQT_CLEAN_NAMESPACE
-DSHAREDIR=\"/usr/share/3ddesktop\" -DSYSCONFDIR=\"/etc\"   -g -O2  -MT 3ddesk.o
-MD -MP -MF ".deps/3ddesk.Tpo" -c -o 3ddesk.o 3ddesk.cpp; \
then mv -f ".deps/3ddesk.Tpo" ".deps/3ddesk.Po"; else rm -f ".deps/3ddesk.Tpo";
exit 1; fi
g++ -Wall -O3 -DQT_CLEAN_NAMESPACE -DSHAREDIR=\"/usr/share/3ddesktop\"
-DSYSCONFDIR=\"/etc\"   -g -O2    -o 3ddesk  3ddesk.o  -lm -lXxf86vm -lXext  
-lSM -lICE -lSM -lICE
if g++ -DHAVE_CONFIG_H -I. -I. -I.    -Wall -O3 -DQT_CLEAN_NAMESPACE
-DSHAREDIR=\"/usr/share/3ddesktop\" -DSYSCONFDIR=\"/etc\"   -g -O2  -MT
3ddeskd.o -MD -MP -MF ".deps/3ddeskd.Tpo" -c -o 3ddeskd.o 3ddeskd.cpp; \
then mv -f ".deps/3ddeskd.Tpo" ".deps/3ddeskd.Po"; else rm -f
".deps/3ddeskd.Tpo"; exit 1; fi
3ddeskd.cpp: In function 'void draw_digit(int, float, float)':
3ddeskd.cpp:634: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccmU7EAM.out file, please attach this to
your bugreport.
make[1]: *** [3ddeskd.o] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/3ddesktop-0.2.9'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.48746 (%build)


Expected results:
RPM should be built 

Additional info:
Comment 1 Naresh 2006-04-06 05:19:51 EDT
Created attachment 127400 [details]
3ddesktop crashing the gcc4 in fedora core 5
Comment 2 Jakub Jelinek 2006-04-06 07:46:56 EDT
Tracking upstream.
Comment 3 Jakub Jelinek 2006-04-27 14:43:16 EDT
*** Bug 190115 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2006-05-02 06:18:45 EDT
*** Bug 190369 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.