Bug 190145 - package assume Qt library (3.3.6)
package assume Qt library (3.3.6)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-qtimm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2006-04-27 20:59 EDT by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 04:08:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2006-04-27 20:59:30 EDT
Description of problem:
I have Qt-3.3.3 installed on system and did yum upgrade to the latest
scim-qtimm. Tried to start kedit in ja_JP after installation and recived the
following error:

Conflict in /usr/lib/qt-3.3/plugins/inputmethods/libqscim.so:
  Plugin uses incompatible Qt library (3.3.6)!

Version-Release number of selected component (if applicable):
scim-qtimm-0.9.4-3

How reproducible:
Always

Steps to Reproduce:
1.have qt-3.3.3 on system
2.yum upgrade to the latest scim-qtimm
3.start kedit in ja_JP
  
Actual results:
Conflict in /usr/lib/qt-3.3/plugins/inputmethods/libqscim.so:
  Plugin uses incompatible Qt library (3.3.6)!

Expected results:
during installation/upgrade qt library should be upgraded?

Additional info:
Comment 1 Jens Petersen 2006-04-28 02:10:23 EDT
Does kedit crash?  kedit works ok with qt-3.3.6?
Comment 2 Lawrence Lim 2006-04-28 02:26:52 EDT
No crashing. Just that no SCIM action. Unable to use scim to input native chars.
Comment 3 Jens Petersen 2006-04-28 02:47:51 EDT
Ok, I'd really rather not require a specific version of qt for scim-qtimm
unless absolutely necessary.  I think it is fair to assume people running
fc6 will have the latest version of qt installed.
Comment 4 Ngo Than 2006-04-28 04:31:00 EDT
Jens, this problem can be avoided if we have require qt >= 3.3.6 for scim-qtimm.
so i think this require should be added.
Comment 5 Jens Petersen 2006-06-06 04:08:47 EDT
Should get fixed in 0.9.4-4.

Note You need to log in before you can comment on or make changes to this bug.