Bug 190164 - xchat segfaults when open in WindowMaker
xchat segfaults when open in WindowMaker
Status: CLOSED DUPLICATE of bug 188894
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-28 09:40 EDT by David Kovalsky
Modified: 2014-03-31 19:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 08:37:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2006-04-28 09:40:40 EDT
Description of problem:
xchat segfaults when open in WindowMaker. Everything is fine when used in Gnome
od KDE.

Version-Release number of selected component (if applicable):
xchat-2.6.0-4
WindowMaker-0.92.0-8.fc5

How reproducible:
always

Steps to Reproduce:
1. yum install WindowMaker (from extras)
2. yum install xchat
3. start a WindowMaker session
4. start xchat from xterm
5. connect to any server (I used FreeNode - freenode.net)
6. try to click on any menu, xchat segfaults
  
Actual results:
segfaults
Expected results:
displays menu

Additional info:
Maybe it also crashes on other platforms, haven't had a chance to try that.
Comment 1 Markus Armbruster 2006-05-10 08:48:17 EDT
Also crashes on opening popups when running under xfce.

#0  0x0080eab8 in strcmp () from /lib/libc.so.6
#1  0x00a68a54 in g_str_equal () from /usr/lib/libglib-2.0.so.0
#2  0x00a415a6 in g_hash_table_lookup () from /usr/lib/libglib-2.0.so.0
#3  0x00a39e11 in g_quark_try_string () from /usr/lib/libglib-2.0.so.0
#4  0x00adc7d9 in g_type_from_name () from /usr/lib/libgobject-2.0.so.0
#5  0x00adcb30 in g_type_from_name () from /usr/lib/libgobject-2.0.so.0
#6  0x00ae1ca0 in g_type_register_static () from /usr/lib/libgobject-2.0.so.0
#7  0x07668545 in gtk_plug_get_type () from /usr/lib/libgtk-x11-2.0.so.0
#8  0x077441d5 in gtk_window_new () from /usr/lib/libgtk-x11-2.0.so.0
#9  0x00ad21c9 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#10 0x00ac37a9 in g_value_set_static_boxed () from /usr/lib/libgobject-2.0.so.0
#11 0x00ac4f6d in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#12 0x00ad5eca in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
#13 0x00ad6f47 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#14 0x00ad7109 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#15 0x07734c78 in gtk_widget_show () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x07645d11 in gtk_menu_popup () from /usr/lib/libgtk-x11-2.0.so.0
#17 0x0806a4d7 in ?? ()
#18 0x0805691b in ?? ()
#19 0x0764352e in gtk_marshal_BOOLEAN__VOID ()
   from /usr/lib/libgtk-x11-2.0.so.0
#20 0x00ac4f6d in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#21 0x00ad5a3d in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
#22 0x00ad6d0f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#23 0x00ad7109 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#24 0x0772e7e8 in gtk_widget_get_default_style ()
   from /usr/lib/libgtk-x11-2.0.so.0
#25 0x0763cf03 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#26 0x0763e157 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#27 0x0099293a in gdk_add_client_message_filter ()
   from /usr/lib/libgdk-x11-2.0.so.0
#28 0x00a4d15d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#29 0x00a503ef in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#30 0x00a50799 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#31 0x0763e5d4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#32 0x0805d24b in ?? ()
#33 0x0809da32 in xchat_plugingui_remove ()
#34 0x007ba7e4 in __libc_start_main () from /lib/libc.so.6
#35 0x08053dd1 in ?? ()
Comment 2 Markus Armbruster 2006-05-18 08:10:59 EDT
I built current devel myself, same crash.

Then I reran configure without any arguments, recompiled everything, and the
result doesn't crash.
Comment 3 Michael Best 2006-06-22 02:21:47 EDT
I am running Fluxbox and I found that my crash was limited to if I checked off 
Skip Server List on Startup
Comment 4 David Kovalsky 2006-06-22 10:23:35 EDT
Does not make a difference in my case (WindowMaker), crashes anyway.
Comment 5 Kevin Kofler 2007-07-10 08:37:52 EDT

*** This bug has been marked as a duplicate of 188894 ***

Note You need to log in before you can comment on or make changes to this bug.