Bug 188894 - Segfault on starting
Segfault on starting
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
5
i386 Linux
high Severity high
: ---
: ---
Assigned To: Christopher Aillon
: Regression
: 173000 186302 190164 190888 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-13 05:03 EDT by Ignacio Vazquez-Abrams
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version: 2.6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 08:44:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2006-04-13 05:03:09 EDT
Not sure if this is a xchat bug per se, but it's the only app I see it in.

The window flickers into view and then the app crashes. Here's the backtrace:

#0  0x0016aab8 in strcmp () from /lib/libc.so.6
#1  0x00375924 in IA__g_str_equal (v1=0x8a63bc, v2=0x53142d6) at gstring.c:77
#2  0x0034e546 in IA__g_hash_table_lookup (hash_table=0x85eb600, key=0x53142d6)
    at ghash.c:251
#3  0x00346db1 in IA__g_quark_try_string (string=0x53142d6 "GtkComboBoxEntry")
    at gdataset.c:605
#4  0x003e97c9 in IA__g_type_from_name (name=0x53142d6 "GtkComboBoxEntry")
    at gtype.c:2627
#5  0x003e9b20 in check_type_name_I (type_name=0x53142d6 "GtkComboBoxEntry")
    at gtype.c:606
#6  0x003eec90 in IA__g_type_register_static (parent_type=141828944,
    type_name=0x53142d6 "GtkComboBoxEntry", info=0x53f98e0, flags=0)
    at gtype.c:2220
#7  0x0516a3a5 in IA__gtk_combo_box_entry_get_type () at gtkcomboboxentry.c:92
#8  0x004a314d in clearlooks_style_register_type ()
   from /usr/lib/gtk-2.0/2.4.0/engines/libclearlooks.so
#9  0x0525220a in IA__gtk_paint_shadow (style=0x864b238, window=0x8601730,
    state_type=GTK_STATE_NORMAL, shadow_type=GTK_SHADOW_IN, area=0x0,
    widget=0x862fac8, detail=0x5318b51 "entry", x=0, y=0, width=971, height=24)
    at gtkstyle.c:5703
#10 0x0518d77c in gtk_entry_expose (widget=0x862fac8, event=0xbfadca94)
    at gtkentry.c:1380
#11 0x051ff4de in _gtk_marshal_BOOLEAN__BOXED (closure=0x8629768,
    invocation_hint=0xbfadc6ac, marshal_data=0x518d500) at gtkmarshalers.c:83
#12 0x003d07a9 in g_type_class_meta_marshal (closure=0x8629768,
    return_value=0xbfadc6c0, n_param_values=2, param_values=0xbfadc79c,
    invocation_hint=0xbfadc6ac, marshal_data=0xc8) at gclosure.c:567
#13 0x003d1f6d in IA__g_closure_invoke (closure=0x8629768,
    return_value=0xbfadc6c0, n_param_values=2, param_values=0xbfadc79c,
    invocation_hint=0xbfadc6ac) at gclosure.c:490
#14 0x003e3083 in signal_emit_unlocked_R (node=0x86299c8, detail=0,
    instance=0x862fac8, emission_return=0xbfadc95c,
    instance_and_params=0xbfadc79c) at gsignal.c:2476
#15 0x003e3d0f in IA__g_signal_emit_valist (instance=0x862fac8, signal_id=35,
    detail=0, var_args=Variable "var_args" is not available.
) at gsignal.c:2207
#16 0x003e4109 in IA__g_signal_emit (instance=0x862fac8, signal_id=35,
    detail=0) at gsignal.c:2241
#17 0x052ea028 in gtk_widget_event_internal (widget=0x862fac8,
    event=0xbfadca94) at gtkwidget.c:3732
#18 0x051fa334 in IA__gtk_main_do_event (event=0xbfadca94) at gtkmain.c:1380
#19 0x04c2b53f in gdk_window_process_updates_internal (window=0x8601730)
    at gdkwindow.c:2292
#20 0x04c2b6f7 in IA__gdk_window_process_all_updates () at gdkwindow.c:2345
#21 0x0516c4d2 in gtk_container_idle_sizer (data=0x0) at gtkcontainer.c:1117
#22 0x003586e1 in g_idle_dispatch (source=0x8734590,
    callback=0x516c480 <gtk_container_idle_sizer>, user_data=0x0)
    at gmain.c:3796
#23 0x0035a09d in IA__g_main_context_dispatch (context=0x8604188)
    at gmain.c:1916
#24 0x0035d32f in g_main_context_iterate (context=0x8604188, block=1,
    dispatch=1, self=0x8604d70) at gmain.c:2547
#25 0x0035d6d9 in IA__g_main_loop_run (loop=0x85ec200) at gmain.c:2751
#26 0x051fa594 in IA__gtk_main () at gtkmain.c:1001
#27 0x0805d24b in fe_main () at fe-gtk.c:277
#28 0x0809da32 in main (argc=Cannot access memory at address 0x8a63bc
) at xchat.c:1012
#29 0x001167e4 in __libc_start_main () from /lib/libc.so.6
#30 0x08053dd1 in _start ()
Comment 1 Tom Cross 2006-04-14 13:12:43 EDT
I can confirm this problem on Fedora-core-5 x86_64.  Start xchat and it
immediatly segfaults.
Comment 2 Craig Kelley 2006-04-17 09:45:40 EDT
I see the same issue when xchat starts up, but only when I have transparent
backgrounds enabled.  Also, clicking on any menu item causes it to crash.  I've
also locked X11 up by using it under gdb (had to ssh in and kill the process). 
Try moving /.xchat* to a save directory and starting it.  The error xchat gets
from the X server is this:

The error was 'BadAccess (attempt to access private resource denied)'.
  (Details: serial 282 error_code 10 request_code 147 minor_code 1)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Comment 3 Jes Sorensen 2006-04-17 10:49:54 EDT
Seeing similar things here. Also noted that if xchat is running and I hit the
right mouse button anywhere over it, it explodes.

I tried recompiling another version and it does the same, so possibly something
with one of the libraries it's using.

I have a core file if anyone's interested.

Jes
Comment 5 Jeff Garzik 2006-05-23 06:03:29 EDT
ACK.  I see this bug as well.

Given that this app randomly segfaults on startup, and always segfaults when
right mouse button is clicked, I have bumped up the priority and severity both
to High.
Comment 6 Jeff Garzik 2006-05-23 13:41:33 EDT
BTW, can everyone re-test after running "yum upgrade"?
Comment 7 Jeff Garzik 2006-05-27 04:31:05 EDT
OK, I still see the bug, even after 'yum upgrade'.

Pete Zaitcev recommended that I remove everything in /usr/lib[64]/xchat/plugins.
 I did so, and it doesn't appear to crash anymore.  Once restarted xchat once,
though.  We'll see if this lasts...
Comment 8 Jes Sorensen 2006-05-27 05:21:45 EDT
(In reply to comment #7)
> OK, I still see the bug, even after 'yum upgrade'.
> 
> Pete Zaitcev recommended that I remove everything in /usr/lib[64]/xchat/plugins.
>  I did so, and it doesn't appear to crash anymore.  Once restarted xchat once,
> though.  We'll see if this lasts...
> 

Did the same here - no more crashes!
Comment 9 Michael Best 2006-06-22 02:21:38 EDT
I narrowed my crash down to Skip Server List on Startup, but my xchat will start
if I use the no plugins -- xchat -n
Comment 10 Jan Cholasta 2006-08-24 12:06:52 EDT
The bug seems to be located in dbus.so plugin. Everything seems to be ok after
removing it from xchat's plugin directory.
Comment 11 Kevin Kofler 2007-07-10 08:33:10 EDT
*** Bug 186302 has been marked as a duplicate of this bug. ***
Comment 12 Kevin Kofler 2007-07-10 08:34:49 EDT
*** Bug 173000 has been marked as a duplicate of this bug. ***
Comment 13 Kevin Kofler 2007-07-10 08:37:54 EDT
*** Bug 190164 has been marked as a duplicate of this bug. ***
Comment 14 Kevin Kofler 2007-07-10 08:38:41 EDT
*** Bug 190888 has been marked as a duplicate of this bug. ***
Comment 15 Kevin Kofler 2007-07-10 08:44:15 EDT
This issue has been fixed in XChat 2.6.1 according to:
http://sourceforge.net/tracker/?func=detail&atid=100239&aid=1441105&group_id=239
Fedora Core 5 is no longer supported. Fedora Core 6 ships XChat 2.6.6, Fedora 7 
is currently at 2.8.2 (2.8.4 in testing). Therefore I believe this bug not to 
apply to any currently supported version of Fedora anymore.

Note You need to log in before you can comment on or make changes to this bug.