Bug 19025 - firewall-config dumps core
firewall-config dumps core
Status: CLOSED DUPLICATE of bug 19182
Product: Red Hat Linux
Classification: Retired
Component: firewall-config (Show other bugs)
7.3
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Wil Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-13 01:15 EDT by Michal Jaegermann
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-13 10:36:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2000-10-13 01:15:25 EDT
An attempt to start firewall-config ends up with:
Illegal instruction (core dumped)

As the test machine is EV67 (UP1100) then it is not very likely
that this was compiled for a wrong platform.

  Michal
  michal@harddata.com
Comment 1 Michal Jaegermann 2000-10-13 01:19:01 EDT
Oops!  Forgot to add.  Attempts to click on an entry in "System" menu
quietly do nothing and this will quite confusing for somebody new
Comment 2 Harald Hoyer 2000-10-13 04:15:45 EDT
I think this is not a firewall-config problem. In my opinion either glibc, g++
or libqt is the source of the segmentation fault. Could you please make a
# gdb /usr/sbin/firewall-config
gdb > run
gdb > ....
gdb > bt
Comment 3 Michal Jaegermann 2000-10-13 10:36:32 EDT
Distributed executables were stripped.  But anyway:
# gdb /usr/sbin/firewall-config
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "alpha-redhat-linux"...
(no debugging symbols found)...
(gdb) r
Starting program: /usr/sbin/firewall-config 
[New Thread 1024 (LWP 11035)]
Qt: gdb: -nograb added to command-line options.
	 Use the -dograb option to enforce grabbing.
firewall-config: Fatal IO error: client killed

Program exited with code 01.
(gdb) bt
No stack.

Ok, so lets try with '-dograb', like suggested above:

(no debugging symbols found)...
(gdb) set args -dograb
(gdb) run
Starting program: /usr/sbin/firewall-config -dograb
[New Thread 1024 (LWP 11040)]
firewall-config: Fatal IO error: client killed

Program exited with code 01.
(gdb) bt
No stack.
(gdb) quit

I did not realized that this program was using Qt.  Over years I still
have to see a version of Qt and/or KDE which would be not riddled
with weird bugs.
Comment 4 Harald Hoyer 2000-10-16 11:25:11 EDT

*** This bug has been marked as a duplicate of 19182 ***

Note You need to log in before you can comment on or make changes to this bug.