Bug 190369 - Segmentation fault compiling 3dDesk
Segmentation fault compiling 3dDesk
Status: CLOSED DUPLICATE of bug 188125
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 14:06 EDT by Drew DeNardo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-02 06:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source (1.17 MB, text/plain)
2006-05-01 14:06 EDT, Drew DeNardo
no flags Details

  None (edit)
Description Drew DeNardo 2006-05-01 14:06:33 EDT
Description of problem:
Download 3dDesktop 0.2.9
(http://sourceforge.net/project/showfiles.php?group_id=59688&package_id=55898)

As root unpack the .tar.gz file

cd into the 3ddesktop-0.2.9 directory

./configure

make

// omitting initial make output
if g++ -DHAVE_CONFIG_H -I. -I. -I.    -Wall -O3 -DQT_CLEAN_NAMESPACE
-DSHAREDIR=\"/usr/local/share/3ddesktop\" -DSYSCONFDIR=\"/usr/local/etc\"   -g
-O2  -MT 3ddeskd.o -MD -MP -MF ".deps/3ddeskd.Tpo" -c -o 3ddeskd.o 3ddeskd.cpp; \
then mv -f ".deps/3ddeskd.Tpo" ".deps/3ddeskd.Po"; else rm -f
".deps/3ddeskd.Tpo"; exit 1; fi
3ddeskd.cpp: In function ‘void draw_digit(int, float, float)’:
3ddeskd.cpp:634: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccldiHH5.out file, please attach this to
your bugreport.
make[1]: *** [3ddeskd.o] Error 1
make[1]: Leaving directory `/home/ddenardo/download/unpack/3ddesktop-0.2.9'
make: *** [all] Error 2


Version-Release number of selected component (if applicable):


How reproducible:
Repeated 5 times out of 5 tries

Steps to Reproduce:
1.Download 3dDesktop 0.2.9
(http://sourceforge.net/project/showfiles.php?group_id=59688&package_id=55898)
2. As root unpack the .tar.gz file
3. cd into the 3ddesktop-0.2.9 directory
4. ./configure
5. make
  
Actual results:
Segmentation fault

Expected results:
Compiled object code

Additional info:
Comment 1 Drew DeNardo 2006-05-01 14:06:35 EDT
Created attachment 128454 [details]
Preprocessed source
Comment 2 Jakub Jelinek 2006-05-02 06:18:43 EDT

*** This bug has been marked as a duplicate of 188125 ***

Note You need to log in before you can comment on or make changes to this bug.