Bug 190398 - Unicode / IPA displays improperly in oowriter. No outline fonts with IPA symbols available.
Unicode / IPA displays improperly in oowriter. No outline fonts with IPA symb...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 17:58 EDT by Craig Pemberton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 05:53:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Editing a document illustrating the bug. (585.15 KB, image/png)
2006-05-01 17:58 EDT, Craig Pemberton
no flags Details
various fonts (24.43 KB, image/jpeg)
2006-05-03 17:14 EDT, Craig Pemberton
no flags Details

  None (edit)
Description Craig Pemberton 2006-05-01 17:58:25 EDT
Description of problem:

IPA (International Phonetic Alphabet) unicode displays with extra space behind
each letter.


Version-Release number of selected component (if applicable): 2.0.2


How reproducible:

Paste a character.

Steps to Reproduce:
1. Go to http://www.phon.ucl.ac.uk/home/wells/ipa-unicode.htm
2. Scroll down a bit and copy an IPA symbol.
3. Paste it into other text.
  
Actual results:

Extra space behind the symbol. Cursor rests in the proper spot.


Expected results:

Proper spacing.
Comment 1 Craig Pemberton 2006-05-01 17:58:27 EDT
Created attachment 128460 [details]
Editing a document illustrating the bug.
Comment 2 Caolan McNamara 2006-05-02 03:45:59 EDT
I wonder if this is resolved by test update 2.0.2-5.8.2 for fc5, it sounds a
little like the problem of bug 189761
Comment 3 Caolan McNamara 2006-05-03 05:53:56 EDT
Ah I see what's going on now.

Unlike firefox which is primarily for screen display OpenOffice.org is primarily
for creating print documents, so it only sees "outline" fonts, e.g. ttf/afm. So
those IPA characters are not in any ttf/afm font that you have installed, only
in some bitmap font which firefix/mozilla has used as a last ditch glyph
replacement for them but as a bitmap font is a font that OOo doesn't know about
to use for glyph replacement

What you can do to get this working is just install "fonts-japanese" (yum
install fonts-japanese) which include some ttf fonts, one of which (Sazanami
Gothic) has the IPA symbols that you need.

Technically it's not a bug in OOo.
Comment 4 Craig Pemberton 2006-05-03 17:14:20 EDT
Created attachment 128568 [details]
various fonts
Comment 5 Craig Pemberton 2006-05-03 17:16:30 EDT
Sazanami Gothic has the same problem. Also, the IPA symbols come in some of the
standard fonts. Some SIL and Microsoft fonts I installed do work properly.

Some screenshots. Notice that the ipa symbols change occasionally but not always. 

Note You need to log in before you can comment on or make changes to this bug.