Bug 1904030 - [release-4.5] The quota controllers should resync on new resources and make progress
Summary: [release-4.5] The quota controllers should resync on new resources and make p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.z
Assignee: Lukasz Szaszkiewicz
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1904028
Blocks: 1904032 1910096
TreeView+ depends on / blocked
 
Reported: 2020-12-03 11:55 UTC by Lukasz Szaszkiewicz
Modified: 2021-01-20 05:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1904028
: 1904032 (view as bug list)
Environment:
Last Closed: 2021-01-20 05:49:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-policy-controller pull 51 0 None closed Bug 1904030: The quota controllers should resync on new resources and make progress 2021-02-01 18:48:59 UTC
Red Hat Product Errata RHBA-2021:0033 0 None None None 2021-01-20 05:49:51 UTC

Description Lukasz Szaszkiewicz 2020-12-03 11:55:10 UTC
+++ This bug was initially created as a clone of Bug #1904028 +++

+++ This bug was initially created as a clone of Bug #1904026 +++

The quota controllers act on resources retrieved from the discovery endpoint which might contain only a fraction of all resources due to a network error.

Both controllers should periodically resync when new resources are observed from the discovery.

Additionally, the CRQ should always ensure the current set of monitors are running.
The CRQ should not block when new resources are observed (deadlock).

Comment 1 zhou ying 2020-12-15 08:21:21 UTC
Confirmed with payload: 4.5.0-0.ci.test-2020-12-15-072346-ci-ln-x6p47n2 , the issue has fixed:


[root@dhcp-140-138 roottest]# oc get clusterversion 
NAME      VERSION                                           AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.ci.test-2020-12-15-072346-ci-ln-x6p47n2   True        False         5m16s   Cluster version is 4.5.0-0.ci.test-2020-12-15-072346-ci-ln-x6p47n2

Follow steps: 
1) Scale down the CVO to replicas==0;
2) Chang the openshiftapiservers to Unmanaged status;
3) Scale down the openshift apiserver to 0, to turn off the openshift-apiserver;
4) restart all KCMs;
5) Turn on the openshift-apiserver;
6)Create test project and imagestream resource and quota about imagestream:
7) Delete all the imagestream, check the quota :


[root@dhcp-140-138 roottest]# oc get is
NAME                       IMAGE REPOSITORY                                                                  TAGS   UPDATED
rails-postgresql-example   image-registry.openshift-image-registry.svc:5000/zhouy/rails-postgresql-example          
[root@dhcp-140-138 roottest]#  oc create quota test1 --hard=openshift.io/imagestreams=10
resourcequota/test1 created
[root@dhcp-140-138 roottest]# oc describe quota test1
Name:                      test1
Namespace:                 zhouy
Resource                   Used  Hard
--------                   ----  ----
openshift.io/imagestreams  1     10
[root@dhcp-140-138 roottest]# oc delete all --all
......
[root@dhcp-140-138 roottest]# oc get is
No resources found in zhouy namespace.
[root@dhcp-140-138 roottest]# oc describe quota test1
Name:                      test1
Namespace:                 zhouy
Resource                   Used  Hard
--------                   ----  ----
openshift.io/imagestreams  0     10

Comment 5 errata-xmlrpc 2021-01-20 05:49:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.27 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0033


Note You need to log in before you can comment on or make changes to this bug.