Bug 1904032 - [release-4.4] The quota controllers should resync on new resources and make progress [NEEDINFO]
Summary: [release-4.4] The quota controllers should resync on new resources and make p...
Keywords:
Status: CLOSED DUPLICATE of bug 1910096
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.4.z
Assignee: Lukasz Szaszkiewicz
QA Contact: zhou ying
URL:
Whiteboard: LifecycleStale
Depends On: 1904026 1904028 1904030
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-03 11:56 UTC by Lukasz Szaszkiewicz
Modified: 2021-01-11 08:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1904030
Environment:
Last Closed: 2021-01-11 08:25:34 UTC
Target Upstream Version:
mfojtik: needinfo?


Attachments (Terms of Use)

Description Lukasz Szaszkiewicz 2020-12-03 11:56:30 UTC
+++ This bug was initially created as a clone of Bug #1904030 +++

+++ This bug was initially created as a clone of Bug #1904028 +++

+++ This bug was initially created as a clone of Bug #1904026 +++

The quota controllers act on resources retrieved from the discovery endpoint which might contain only a fraction of all resources due to a network error.

Both controllers should periodically resync when new resources are observed from the discovery.

Additionally, the CRQ should always ensure the current set of monitors are running.
The CRQ should not block when new resources are observed (deadlock).

Comment 1 Michal Fojtik 2021-01-02 11:58:21 UTC
This bug hasn't had any activity in the last 30 days. Maybe the problem got resolved, was a duplicate of something else, or became less pressing for some reason - or maybe it's still relevant but just hasn't been looked at yet. As such, we're marking this bug as "LifecycleStale" and decreasing the severity/priority. If you have further information on the current state of the bug, please update it, otherwise this bug can be closed in about 7 days. The information can be, for example, that the problem still occurs, that you still want the feature, that more information is needed, or that the bug is (for whatever reason) no longer relevant. Additionally, you can add LifecycleFrozen into Keywords if you think this bug should never be marked as stale. Please consult with bug assignee before you do that.

Comment 2 Lukasz Szaszkiewicz 2021-01-11 08:25:34 UTC

*** This bug has been marked as a duplicate of bug 1910096 ***


Note You need to log in before you can comment on or make changes to this bug.