Bug 190621 - Mouse randomly clicks
Mouse randomly clicks
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
NeedsRetesting
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 20:41 EDT by Joshua Wulf
Modified: 2014-10-19 18:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 18:34:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2006-05-03 20:41:02 EDT
Description of problem: While typing in a text area, the text cursor randomly
jumps to where the mouse cursor is hovering, as if the left mouse button had
been clicked.


Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2096_FC5

How reproducible: Intermittent but consistent


Steps to Reproduce:
1. Type for any appreciable length of time in a text area on a web page or in a
word processor such as OpenOffice.org
2. Watch as the cursor jumps around.
3.
  
Actual results: Text entry cursor jumps


Expected results: Text entry cursor should not move unless i click the mouse button.

Additional info:
Comment 1 Frank Arnold 2006-05-04 13:24:32 EDT
Touchpad or external mouse?
If touchpad, are you using Synaptics X driver in addition to the kernel driver, 
or just the plain kernel driver?

I guess you have the USB trackpad, so it would be the appletouch kernel driver.
Comment 2 Joshua Wulf 2006-05-22 20:22:11 EDT
I'm just using appletouch.

I'm fairly sure this is not application specific, as it happens in gedit,
openoffice and in html edit areas in firefox. It's really annoying, because I'll
be writing a bugzilla / blog entry, and the focus will go out of the edit area
and onto the web page, if the mouse cursor is sitting outside the edit area.
Then when I hit backspace the browser does a page back, and I lose everything I
typed in...

Comment 3 Frank Arnold 2006-05-23 05:03:43 EDT
(In reply to comment #2)
> I'm just using appletouch.

(I meant synaptics touchpad driver, not the synaptic package manager)

Ok, I think that's the problem. The appletouch driver is rather rudimentary. It
 exposes only raw data from touchpad to userspace. For further tweaking, i.e.
make it less sensitive for touching, you have to use the Synaptics touchpad driver.

1. Do a "yum install synaptics"
2. Edit your /etc/X11/xorg.conf
	* Add a new InputDevice to your ServerLayout

		InputDevice "Synaptics Touchpad"

	* Add a new InputDevice section

		Section "InputDevice"
			Identifier "Synaptics Touchpad"
			Driver "synaptics"
			Option "Device" "/dev/input/mice"
			Option "Protocol" "auto-dev"
			...
			...
		EndSection

3. Tweak the values in Synaptics "InputDevice" section to your needs. See
"synaptics" man page for explanation of the values. To give you a starting point
here is my current X config:

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=126709
(Middle and right button mapped to upper left and upper right corner)

There's also a graphical configuration tool available through extras
(gsynaptics). I haven't tried it yet though.

HTH
Comment 4 Joshua Wulf 2006-05-24 21:34:36 EDT
Thanks for the pointers Frank. 

A couple of things:

1) I don't think that the issue is due to hyper-sensitivity of the touch pad.
That mouse cursor is "clicking" when I'm not touching the touch pad at all, just
typing. At first I thought it might be hyper-sensitivity, but now I'm sure it's
something else, after consciously observing when it happens, and trying to
simulate it by brushing and tapping the mousepad. 

2) I tried the synaptics driver thing, but it stops the touchpad from
functioning at all!

I added these lines to xorg.conf:

In ServerLayout:

	InputDevice "Synaptics Touchpad"
later...

Section "InputDevice"
		Identifier "Synaptics Touchpad"
		Driver "synaptics"
		Option "Device" "/dev/input/mice"
		Option "Protocol" "auto-dev"
EndSection

[jwulf@localhost ~]$ rpm -q synaptics
synaptics-0.14.4-7

i also tried it with all your options. With your options loaded I can run
gsynaptics (but still not use the touchpad). Without your options gsynaptics
complains about SHMConfig not being set to true.
Comment 5 Frank Arnold 2006-05-25 02:00:08 EDT
(In reply to comment #4)
> 1) I don't think that the issue is due to hyper-sensitivity of the touch pad.

Maybe. But I can't reproduce it with my Powerbook. We'll see.

> 2) I tried the synaptics driver thing, but it stops the touchpad from
> functioning at all!

Sh*t. I forgot a line.

Section "InputDevice"
		Identifier "Synaptics Touchpad"
		Driver "synaptics"
		Option "Device" "/dev/input/mice"
		Option "Protocol" "auto-dev"
		Option "SendCoreEvents" "true"
		...
		...
EndSection

Without the option "SendCoreEvents" it won't work. If it doesn't work with this
option either, please attach your full xorg.conf.

> Without your options gsynaptics
> complains about SHMConfig not being set to true.

Makes sense. With SHMConfig you'll be able to manipulate the driver settings
without restarting X. There are some command line tools, too. OTOH this means
everbody with access to your machine can manipulate it, but it's not that
critical on a notebook.
Comment 6 Dave Jones 2006-10-16 15:08:34 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 7 Frank Arnold 2006-10-30 05:55:53 EST
Well, I still think it's the sensitivity of the touchpad. There are sensors
spread across the pad which are evaluated by the driver. The signals from those
sensors are a bit flaky, especially prone to temperature changes. Maybe the raw
appletouch driver does have some problems with it, but it's nothing that can't
be trimmed down with Synaptics.

IMHO this one can be closed.

Note You need to log in before you can comment on or make changes to this bug.