Bug 1906714 - Enable OpenType related features with HarfBuzz
Summary: Enable OpenType related features with HarfBuzz
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: freetype
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1136522 (view as bug list)
Depends On:
Blocks: 1853937
TreeView+ depends on / blocked
 
Reported: 2020-12-11 09:14 UTC by Akira TAGOH
Modified: 2021-03-03 16:54 UTC (History)
13 users (show)

Fixed In Version: freetype-2.10.4-3.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-05 11:48:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Akira TAGOH 2020-12-11 09:14:52 UTC
Description of problem:
FreeType has supported some OpenType related features since 2.5.3 by linking HarfBuzz at the build time, and continue growing more since then.

Although our build keeps disabling this feature, we have Bug#1853937 now and it is hard to fix without enabling HarfBuzz in FreeType. it may be time to enable it in Fedora too because it may be stable enough that they spent 6 years or so since 2.5.3 has been released.

I'm filing this RFE separetely because it would be better informing this as a f34 Changes proposal and good to keep it on track.

Comment 1 Marek Kašík 2020-12-15 17:10:32 UTC
Hi,

I agree with the change. But I'm lost with the bootstrap process (I'm sorry about that, I didn't need it until now). I understand how should the changes look in the spec file thanks to you but the process of rebuilding freetype isn't clear to me.

I think it should go this way:

1) bump release
2) build freetype with bootrap on (== without harfbuzz and the build has ~bootstrap suffix)
3) build harfbuzz with the previously build freetype
4) build freetype without bootstrap which will use the previously built harfbuzz

I'm not sure how to execute 4). Is it by changing the bcond in the spec file to "without" instead of "with" or by passing a parameter to the build?
Does it need to be manual or do we have an automation for this?
Do we need to do this every time we need to build freetype or harfbuzz?

Comment 2 Akira TAGOH 2020-12-16 11:45:47 UTC
Actually I have same question and not exactly sure how that will be done. but after looking at some packages that support bootstrap like glibc, I see they didn't touch a flag in spec file since it has been added. they disable bootstrap by default and looks like expecting enabling boostrap by --with bootstrap from rpmbuild side.

Comment 3 Marek Kašík 2020-12-16 11:58:37 UTC
I'll ask some of my colleagues then. Regards

Comment 4 Marek Kašík 2020-12-21 18:16:56 UTC
I think that I've figured the process out thanks to Jan Grulich and https://docs.fedoraproject.org/en-US/packaging-guidelines/#bootstrapping. However I'm not sure whether it is needed to track this as a proposal but if you think that it is needed we can do this at January as there is time for these until 19th of January (I don't consider this a System Wide change).

Comment 5 Akira TAGOH 2020-12-22 07:35:27 UTC
Thank you for working on this. I hope this wouldn't negatively affect too much but that would be nice if we can get more testers and feedback on it by advertising this with Change proposal since users is somewhat sensitive on the changes in freetype and rendering.

Comment 6 Marek Kašík 2021-01-12 12:56:59 UTC
I've proposed this at https://fedoraproject.org/wiki/Changes/EnableHarfBuzzInFreeType.

Comment 7 Akira TAGOH 2021-01-13 04:57:08 UTC
Thank you so much. that looks good to me.

Comment 8 Marek Kašík 2021-02-05 11:48:59 UTC
I've built the freetype with enabled HarfBuzz support successfully in rawhide.

Comment 9 Mamoru TASAKA 2021-02-07 12:33:14 UTC
Perhaps this is causing the issue: bug 1925922

Comment 10 Marek Kašík 2021-03-03 16:54:12 UTC
*** Bug 1136522 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.