Bug 1907320 - python-reportlab fails to build with Python 3.10: free(): invalid pointer
Summary: python-reportlab fails to build with Python 3.10: free(): invalid pointer
Keywords:
Status: CLOSED DUPLICATE of bug 1904379
Alias: None
Product: Fedora
Classification: Fedora
Component: python-reportlab
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio T. sagitter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1904379
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-12-14 08:46 UTC by Tomáš Hrnčiar
Modified: 2021-01-09 10:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-09 10:55:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-12-14 08:46:12 UTC
python-reportlab fails to build with Python 3.10.0a3.

Built story contains 1833 flowables...
Saved "/builddir/build/BUILD/reportlab-3.5.56/docs/reportlab-userguide.pdf"
"/usr/bin/python3" genuserguide.py 
free(): invalid pointer
/var/tmp/rpm-tmp.HQaN9m: line 67:  8411 Aborted                 (core dumped) /usr/bin/python3 docs/genAll.py

I suspect PIL (pillow) is broken. See also bz1899498 and bz1898977.

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01829299-python-reportlab/

For all our attempts to build python-reportlab with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-reportlab/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2021-01-09 10:55:44 UTC

*** This bug has been marked as a duplicate of bug 1904379 ***


Note You need to log in before you can comment on or make changes to this bug.