Bug 190784 - glibc_2.0 missing
Summary: glibc_2.0 missing
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 190785 190786 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-05 06:05 UTC by Markus Kalske
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 07:43:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Markus Kalske 2006-05-05 06:05:21 UTC
Description of problem:
I installed updates via yum to FC4 and after that I noticed that libraries 
were changed, because I couldn't even use ls command. I upgraded to FC5 and 
this fixed the libraries, but few important program doesn't work anymore. I 
found this problem by some error messages containing shared libraries file or 
directory not found. Only missing library seems to be libc_2.0 from libc-
2.4.so. I can find that missing piece from old libc.so.6, but when I remove 
the soft link libc.so.6 and replace that with the old libc.so.6 everything 
breaks apart. Ofcourse these libraries aren't compatible by just copying. I 
would like to know how could I import the missing glibc_2.0 support or get a 
patch which would do it for me. I wonder why old libraries are modified on FC4 
update, giving frustrating work. Including this glibc_2.0 support would fix 
the broken softwares. I don't have or can't get the source codes to these 
broken softwares anywhere.

Version-Release number of selected component (if applicable):
libc-2.4.so and libc.so.6

How reproducible:
Everytime.

Steps to Reproduce:
1. Just install FC5 and the library is missing...
2.
3.
  
Actual results:
Error while loading shared libraries, No such file or directory
(missing glibc_2.0)

Expected results:


Additional info:

Comment 1 Jakub Jelinek 2006-05-05 07:37:07 UTC
*** Bug 190786 has been marked as a duplicate of this bug. ***

Comment 2 Jakub Jelinek 2006-05-05 07:37:42 UTC
*** Bug 190785 has been marked as a duplicate of this bug. ***

Comment 3 Jakub Jelinek 2006-05-05 07:43:29 UTC
Please read FC5 release notes, LinuxThreads support has been deprecated for 3
years and has been removed in FC5, won't ever come again.
Programs linked against glibc 2.0 will only work if they don't reference
errno or h_errno variables.
If you really need to run software built against glibc 2.0 (i.e. something
the vendors haven't bothered to rebuild during last 8 years), then you either
need to stay with older distributions, or install those distros in a chroot
and run the broken software there.


Note You need to log in before you can comment on or make changes to this bug.