Bug 190801 - Crash on Refresh Repositories
Crash on Refresh Repositories
Status: CLOSED DUPLICATE of bug 190653
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 05:31 EDT by John Williams
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 07:03:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Williams 2006-05-05 05:31:18 EDT
Description of problem:

Crash on Refresh Repositories

Version-Release number of selected component (if applicable):
1.0

How reproducible:
Every time

Steps to Reproduce:
1. Start yumex
2. Refresh repositories
3. Gaze at crash dialog (text below)
  
Actual results:
Crash

Expected results:
No crash

Additional info:


Component: yumex
Version: 1.0.0
Summary: TB0a016f5d updates.py:533:getObsoletesList:AttributeError: Updates
instance has no attribute 'obsoletes'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 180, in on_repoRefresh_clicked
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 899, in setup_yum
    self.yumexbase.build_package_lists( self.recentlimit, pkglists )
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 499, in
build_package_lists
    updates = self.up.getUpdatesList() + self.up.getObsoletesList()
  File "/usr/lib/python2.4/site-packages/rpmUtils/updates.py", line 533, in
getObsoletesList
    tmplist = self.obsoletes.keys()
AttributeError: Updates instance has no attribute 'obsoletes'

Local variables in innermost frame:
newest: 0
self: <rpmUtils.updates.Updates instance at 0xb3888c6c>
arch: None
name: None
Comment 1 Tim Lauridsen 2006-05-05 07:03:48 EDT

*** This bug has been marked as a duplicate of 190653 ***

Note You need to log in before you can comment on or make changes to this bug.