Bug 190844 - Whenever I start the program "pirut", it gives an "unhandled exception".
Whenever I start the program "pirut", it gives an "unhandled exception".
Status: CLOSED DUPLICATE of bug 186545
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 13:23 EDT by Mihir Sampat
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 13:50:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core Dump for /usr/sbin/pirut unhandled exception (877 bytes, application/octet-stream)
2006-05-05 13:23 EDT, Mihir Sampat
no flags Details

  None (edit)
Description Mihir Sampat 2006-05-05 13:23:28 EDT
Description of problem:
I had a Fedora Core 4 system  (P4 - 2Ghx, 512 Mb RAM, 80 Gb HDD, Aopen i865
motherboard) which I upgraded to Core 5 today. Immediately upon upgradation, I
logged into GNOME as root, and started a program "Add or Remove Programs" and it
shows an "unhandled exception". This program is probably /usr/sbin/pirut. I have
attached the core dump.

Version-Release number of selected component (if applicable):
/usr/sbin/pirut program that comes bundled with FC5 (donno version no bcoz I
cant start it)

How reproducible:
Cant tell, but I am sure it is possible.

Steps to Reproduce:
1. Install Fedora Core 4
2. Upgrade to Fedora Core 5
3. Login to GNOME as "root" and run "Add or Remove Programs" from the
Applications Menu.
  
Actual results:


Expected results:


Additional info:

Here's the output it spat out:

Component: Software Manager
Summary: TB43b34ebc GroupSelector.py:407:populateCategories:TypeError: iter
should be a GtkTreeIter

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 363, in ?
    main()
  File "/usr/sbin/pirut", line 359, in main
    pm.run()
  File "/usr/sbin/pirut", line 288, in run
    self._showBrowse()
  File "/usr/sbin/pirut", line 225, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 410, in
doRefresh
    self.populateCategories()
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 407, in
populateCategories
    sel.select_iter(i)
TypeError: iter should be a GtkTreeIter

Local variables in innermost frame:
i: None
cats: []
self: <pirut.GroupSelector.GroupSelector instance at 0xb798e26c>
sel: <gtk.TreeSelection object (GtkTreeSelection) at 0xb79c6cd4>
Comment 1 Mihir Sampat 2006-05-05 13:23:28 EDT
Created attachment 128668 [details]
Core Dump for /usr/sbin/pirut unhandled exception
Comment 2 Jeremy Katz 2006-05-05 13:50:20 EDT

*** This bug has been marked as a duplicate of 186545 ***

Note You need to log in before you can comment on or make changes to this bug.