Bug 1908657 - marketplace operator not Available and Degraded due to OperatorExited, even though marketplace-operator is running, causing upgrade to be stalled. [NEEDINFO]
Summary: marketplace operator not Available and Degraded due to OperatorExited, even t...
Keywords:
Status: CLOSED DUPLICATE of bug 1909217
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-17 09:38 UTC by ggore
Modified: 2020-12-25 05:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-18 17:18:14 UTC
Target Upstream Version:
ggore: needinfo? (krizza)


Attachments (Terms of Use)

Description ggore 2020-12-17 09:38:06 UTC
Description of problem:

Upgrade from 4.5.16 to 4.5.20 stuck with marketplace operator in degraded state with reason as OperatorExited, even though marketplace-operator pod is running.

marketplace                               4.5.16   False      False        False     17h


operator status shows OperatorExited:
~~~
status:
  conditions:
  - lastTransitionTime: '2020-11-21T10:22:19Z'
    message: The operator has exited
    reason: OperatorExited
    status: 'False'
    type: Progressing
  - lastTransitionTime: '2020-12-01T14:17:55Z'
    message: The operator has exited
    reason: OperatorExited
    status: 'False'
    type: Available
  - lastTransitionTime: '2019-10-16T13:50:04Z'
    message: The operator has exited
    reason: OperatorExited
    status: 'False'
    type: Degraded
  - lastTransitionTime: '2020-10-10T22:12:21Z'
    message: Marketplace is upgradeable
    reason: OperatorExited
    status: 'True'
    type: Upgradeable
~~~


marketplace-operator pod is running:
~~~
NAME                                  READY  STATUS   RESTARTS  AGE
certified-operators-d7959bc47-d5x24   1/1    Running  0         21h
community-operators-548b56497b-gr5nw  1/1    Running  0         10d
marketplace-operator-8d4dbd8c5-cpjbd  1/1    Running  0         17h
redhat-marketplace-7f59b45886-np6kg   1/1    Running  0         1d
redhat-operators-8658669bd6-g5rjb     1/1    Running  0         19h
~~~


Expected results:
If marketplace-operator pod is running then marketplace CO should not show OperatorExited and upgrade should continue.

Additional info:
- deleting marketplace-operator pod manually also does not make any difference.

- cluster-version-operator pod shows these operators are still updating.
2020-12-02T07:39:58.018878479Z E1202 07:39:58.018854       1 sync_worker.go:329] unable to synchronize image (waiting 2m52.525702462s): Some cluster operators are still updating: marketplace, node-tuning, storage

Comment 3 Kevin Rizza 2020-12-18 17:18:14 UTC
Looks like this is a duplicate of a bz that has already been opened of an existing issue. Closing as dup.

*** This bug has been marked as a duplicate of bug 1909217 ***


Note You need to log in before you can comment on or make changes to this bug.